I recently had two 320GB HDDs on Raid 0 running on my main computer, and decided to split it in order to use one of the HDDs on another computer.

A windows system image of about 150GB was made on a 2TB external drive. The two 320GB disks have been formated and one of them is already in use in another computer.

When I tried to restore the image onto the formatted 320GB drive, I got an error saying that "No disk that can be used for recovering the system disk can be found".

I then learned that windows wont let system images from bigger drives (the 640GB raid 0 one) be restored to smaller ones, even if the image is smaller than the target drive. Resizing the external drive isn't really an option, since it's almost full.

Is there a way to still restore the image?

  • What was the backup program? acronis wouldnt have had that limitation, I have done all kinds of mixups with it. Also programs that can access the "image" file to change it a bit are usefull, so a person can toss something when it is an actual size problem. programs like XXclone (not xxcopy) could come in handy to shift this stuff around and still get boot, although I only tested it back before it was 7 capable. – Psycogeek Feb 5 '12 at 2:49

Use Acronis to convert the VHD image to an Acronis tib image, then use Acronis to install the tib image on the smaller drive space.

  • Worked great. The conversion wasn't even needed; Acronis was able to restore the image without the weird limitations of the default windows backup software. – ememorais Feb 6 '12 at 0:57

Window's Backups can be mounted as VHD files.

I would mount the backup file on a separate computer and resize the partition within the VHD. You'll have to use a Windows based partition manager because AFAIK GPart cannot mount VHDs.

While I am uncertain if this solution will work, it will resize the partition inside the backup file, possible alleviating the restriction you are running into.

  • I tried shrinking the partition within the VHD so that it was even smaller than the drive but I still couldn't restore it. – Neil Jul 30 '15 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.