I managed to set synergy (ubuntu box as server and mac as client - it doesn't work the other way around). Currently I'm running:

synergys -f
synergyc -f SERVERNAME

on the ubuntu and mac respectively. If I drop the -f then everything works, but in the background... My questions is how can I close the two when they run in the background?


You can either use the task manager to find the process and terminate it or a console command such as killall synergys, which will close all running processes with the name "synergys".

Another way is to find out the process ID first using ps ux or pidof synergys and then killing it with kill <process ID>.


There are instructions in the official guide on starting automatically (and killing an existing process) synergy when a user logs in for Windows, OSX and Unix/Linux, you may be interested in setting that up:

It would be much more comfortable if you don't have to manually launch it every time you log in your session.

  • Your link is broken. – Mitch Sep 25 '18 at 8:05

For cases where you launch the UI, and for some reason the status bar icon is unavailable (This happened to me), if you close the UI then you can't open the UI again for that instance of synergy and hence can't stop or control the server and you can't even exit, even if you use killall synergys the app respawns on its own. I found that you have to

killall synergy 

This will kill the active synergy UI, then you should

killall synergys

This will kill the synergy server.


None of these answers worked for me. The processes can't be killed, either individually or with killall. The info in this thread did the trick for me on Ubuntu 18.04 (sudo systemctl stop synergy):

You can disable Synergy temporarily by stopping the background service. We'll be adding a feature to do this in 2.1 which is due early 2018. Until then, it has to be done manually.


Open the Services program (Run > services.msc) and find the Synergy service. Double click it to edit the service, and choose Manual from "Startup type", then click Stop to stop the background process, and Start to start it again.


Open the Terminal app and run this command:

launchctl unload /Library/LaunchAgents/com.symless.synergy.synergy-service.plist

To enable it again, run this command instead:

launchctl load /Library/LaunchAgents/com.symless.synergy.synergy-service.plist


Open the Terminal program and run:

sudo systemctl stop synergy

And then to re-enable it:

sudo systemctl start synergy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.