15

I was playing with the new tmux version of Byobu, and I saw this command:

  • Ctrl-Shift-F5 -Change status bar's color randomly

But, now that I've finished playing I'd like to switch the colours back to the defaults. But I can't find how to do this. I've closed down byobu with no success.

Is there a key combination I've missed?

3 Answers 3

7

Or by running byobu-select-profile.

3
  • 1
    +1 but tmux: unknown option -- X byobu 5.21, tmux 1.6 when I tried changing settings
    – kfmfe04
    Commented Feb 19, 2013 at 10:35
  • @kfmfe04 same issue.
    – Baskaya
    Commented Nov 21, 2013 at 10:20
  • 1
    Backup your config before doing that. I screwed up my status bar colors, another bug reported here.
    – Pablo A
    Commented Sep 17, 2017 at 5:17
19

Removing the tmux.color file will reset this:

rm ~/.byobu/color.tmux
1
  • 7
    after closing session and refreshing with F5, this worked for me
    – Akronix
    Commented Sep 20, 2016 at 14:16
4

Hit Shift+F5, wait 2 seconds, and repeat until you see your status bar come back. This will cycle through prepackaged status lines in ~/.byobu/status.

For me, 2 out of 3 status lines were too wide for my terminal, which was 80 columns wide. When the content is too wide, the status bar just doesn't display at all.

You could also edit ~/.byobu/status, go to the line tmux_right="#foo bar baz" and put # in front of things like bar and baz, save the file, wait, and the status bar will refresh. What you're doing is disabling the display of those options until the line is narrow enough to fit in your terminal.

Control+Shift+F5 will change the color of the status bar. I also thought it stopped the status bar from displaying, but I think this is because of the delay between pressing it and the effect. One handy thing you can do is use a different color for servers.

All of this info I got from kirkland in #byobu on freenode

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .