Running Windows 7, 32-bit Professional. My printer is an HP OfficeJet Wireless 8500. It's connected to my network wirelessly through TCP/IP as a standalone device.

I was having some print problems awhile back and had to do some print spooler stuff as part of my troubleshooting (stopping the Print Spooler service, clearing the print spooler files from C:\Windows\System32\spool\PRINTERS and then restarting the service). I've finally narrowed it down to it being application specific, so that's that.

However, as a leftover from all that troubleshooting, my printer icon is stuck in the tray - when I mouseover the icon, Windows says that there is 1 document(s) pending for my username. However, when I open up that printer's queue, there's nothing in there.

I restarted the Printer Spooler service and also checked C:\Windows\System32\spool\PRINTERS if there's anything in there - nothing. I did a quick Google search and an answer from one of those "reps" at the Microsoft Socialnet site says for me to uninstall and reinstall the printer.

The funny thing is, when I send print jobs, they print just fine - that 1 mystery document stuck in queue isn't stopping anything from happening.

Short of having to do that, are there any other quick troubleshooting steps I may be missing?

  • 2
    thing to TRY, 1) because you can install another "printer" (more like an icon to it) without re-installing the drivers, that might help, and better than re-installing. 2) I tried a reg scan and only thing that changed EVER , was HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers\PRINTERNAME\DsSpooler printstart and printend times , which are now at 0. 3) Starting an stopping the spooler, With the printer ON, as any cancel gets acknowleged? 4) General reboot? 5) getting desperate, go into the properties for the printer and turn off spooling (for that printer) – Psycogeek Feb 8 '12 at 22:57
  • 2
    . . . In Advanced , Same thing turn off Sharing also (temporarily) for that printer , in printer porperties. There is a Microsoft Fix-It for the print spooler, I doubt it addresses this actual problem. Having a stuck item there is not rare on the web, having Nothing there to cancel is rare. Another possible would be to get another item in the quo, and Cancel ALL (verses cancel job). – Psycogeek Feb 8 '12 at 22:59

I had a similar problem in Windows Vista. By going to Control Panel/Administrative Tools/Services, I was able to re-start the Print Spooler, which was my "original problem." But I couldn't get the printer to do anything because the spooler would quit whenever I tried to print anything - including the "Test Page." When I'd open the printer's print que on the Printers' page of the Control Panel, it would show an empty list. But if I just hovered over the printer's icon on the Printers' page, it showed that there was ONE document in it. I couldn't delete the document, however.

Finally, I declared another printer to be my default printer. Once that was done, I went back to my "problem printer" and was able to delete the document. I went back to the Printers' page of the Control Panel and re-declared the correct printer to again be my default printer. I was able to print a "test page," so I exited the Control Panel and tried printing a document. Success!


I didn't want to do it, but I restarted my computer - cleared the problem right away.

Though if I were running a Windows 2003/2008 server, I would hate to have to restart the domain controller just to get rid of this irritating problem. If I run into this problem again, I'm going to try that remove printer/reinstall printer thing.

  • Five years after your original post, I continue to have this problem -- Windows 7, 64-bit, Xerox networked printers. You should not need to do a full restart -- a Log off should also clear the problem right away. I would dearly like to find a solution that did not involve closing all running programs. – JonathanDavidArndt Jun 30 '17 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.