The virtual machine is running on VMware ESXi 5.0.0.

I have turned the virtual machine off and when I go to Edit Settings / Hard Disk 1, the Provisioned Size is greyed out and I cannot change it. See the picture for more details.

Any idea how to make the hdd bigger in this case? Last time (I think it was VMWare ESXi 4.x) was able to do it.

enter image description here


You can't resize an IDE Disk only SCSI Disks.

Follow this guide to convert IDE to SCSI; then you can resize the partition.


| improve this answer | |

Remove snapshots from the vm if there are any.

This will re-enable the options

| improve this answer | |

Have you tried right-clicking on the VM in the vSphere Client (which is where your pictures are from) and selecting Edit Properties?

It is possible that you can't enlarge that disk, perhaps because of the format (Thick Provisioned Eager Zeroed). If so, you could add another disk instead.

As for changing the disk, remember that will actually change the size and more of the disk without changing the data on the disk: thus, the partition will be the same size as before, the partition layout will be the same, and so on - except the system may report the partition tables as corrupt because the size has changed.

You'd probably be better off putting in a new disk; as far as I know, Windows doesn't have anything like LVM which would allow you to stretch a disk volume across multiple physical partitions or disks.

| improve this answer | |
  • The bottom picture is after clicking "Edit Properties". I already increased Windows XP partition by increasing the size of Virtual Hard Disk and then resizing partition under Windows. – Radek Feb 9 '12 at 0:52
  • @Radek: You're right about that; I was thinking of the Add Disk screen I think. Your last statement confuses me: does this mean you've already solved your problem? (If so, document it here and mark your own answer as accepted.) – Mei Feb 9 '12 at 1:09
  • Sorry for the confusiong ... I meant that I had resized hdd follow above steps before. It's not working now. – Radek Feb 9 '12 at 1:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.