After using a tablet for a while and disconnecting it, this weird extra artifact has appeared beside my cursor, but only on my second display. The cursor doesn't distort like mentioned in other questions I've seen here, it just has the extra bar on the left side.

weird cursor

Changing pointer theme to Windows Black or turning on pointer trails gets rid of it, but I don't really want to use a workaround.

I've tried

  • restarting (because it fixes a lot more things than it should, eh?) Didn't work.

  • reconnecting the tablet and undoing all my settings changes (I'd set the pen input area to only my first display, and turned off 'press and hold' because it was getting in the way of drawing). Didn't work.

  • shifting windows between the two displays. The cursor is specific to only the second display.

  • checking for driver updates, my mouse and tablet drivers are up to date.

  • disconnecting/reconnecting the second display. Didn't work.

The funny thing is I've used that tablet (an old Wacom CTE-640) on this machine before and I've never encountered this problem.

Does anyone have any idea what this is?

  • superuser.com/questions/375266/… Check out this question, it is probably a very similar occurance.
    – Psycogeek
    Feb 9, 2012 at 8:45
  • No luck, I don't even have the Synaptics software installed ;) I need to go home, I've uninstalled SetPoint (Logitech's mouse software), let's see what happens tomorrow.
    – Seyren
    Feb 9, 2012 at 10:39
  • uninstalling the software itself might have been a bit drastic :-) originally i was thinking more along the lines of finding the offending curser grafic and changing it, or matching the grafics of the same size? or there was taking cursers out of hardware acceleration (back in xp) .
    – Psycogeek
    Feb 9, 2012 at 21:40
  • It was most of the cursors except the pointer, but the pointer had it in browser windows and not on VS2010. Weird, huh? Anyway the problem is gone, I'll now try installing the new version of SetPoint. Honestly I don't really think SetPoint was the problem though.
    – Seyren
    Feb 10, 2012 at 1:33
  • 1
    SetPoint reinstalled, no problem. I don't think it was SetPoint.
    – Seyren
    Feb 10, 2012 at 6:56

4 Answers 4


I've seen this suddenly occur on rotated monitors. Setting the rotation to normal and then setting it back to 90 degrees seems to resolve it.

  • I didn't think to mention that my monitor was rotated! Changing the answer to this since it fits the conditions and doesn't require disabling anything.
    – Seyren
    May 21, 2014 at 1:30
  • This really worked! I can't believe this doesn't have more upvotes...
    – dance2die
    Aug 27, 2014 at 15:28
  • Rotating the other display made the situation inverse: now to cursor shows correct on the previously wrong screen and vice versa. Setting both monitors back to normal rotation again changes the cursor back. Still a weird cursor on the primary screen.
    – MikkoP
    May 13, 2016 at 15:59

Disable pointer shadow within the cursor menu. I was having the same issue and this seemed to fix the artifact on the second window.

  • I've never been able to reproduce the issue - I guess I'll mark this as the answer since it worked for you. Thanks!
    – Seyren
    Dec 5, 2013 at 1:01
  • 1
    Awesome. I changed up my monitors so side one is portrait flipped and there were artifacts (lines showing up) under the mouse pointer. Unticking enable shadow fixed it for me. Thanks!
    – Krista K
    Apr 16, 2014 at 21:10
  • This problem suddenly appeared when using a rotated 2nd monitor. Removing the mouse shadow from mouse settings solved it. Apr 29, 2015 at 10:49

Below steps should work in most of the cases and both with Win 10 or Win 7.

  1. Press WindowsKey + U
  2. Go the magnifier from the left menu
  3. Set the zoom to 100%
  4. Minimize the magnifier window and let it run
  5. The magnifier application needs to be running
  • This doesn’t explain what the character in question is
    – Ramhound
    Apr 4, 2018 at 11:45
  • Seems to have fixed my issue.
    – RaoulRubin
    Jul 22, 2022 at 13:08
  • Only thing that worked for me Sep 27, 2023 at 11:17

This worked for me:

  1. Go to Control Panel and select Mouse Properties
  2. Under the "Pointers" Tab, change the "Scheme" to any other scheme and click apply.
  3. Let the new settings apply and move your mouse around. The cursor should be fine now.
  4. If you want the original scheme, go back into Mouse Properties -> Pointers -> "Scheme", select the original scheme you had, and click apply.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .