2

I have an external hard drive that does not mount to my Mac laptop, nor is it visible in Disk Utility. It is, however, visible in the System Profiler under the USB section. Any suggestions as to how I can get this drive to mount?

Thanks.

4 Answers 4

1

The only theory I can imagine for what you're describing is if you're booting into Safe Mode and if you are, Lion won't mount your 'unsafe' drives or even recognise them (in some instances).

nb. OS X will still write hidden dot files (.fsevents .DS_store .Trashes etc) to those unmounted drives / partitions / filesystems.

Although this theory is unlikely (as you'd surely notice the lengthy boot time - during which OS X rebuilds all the cache / kexts / preference files), you can find out whether you're booting into Safe Mode (and further investigate your issue) by opening the Terminal and sudo'ing to root.

To determine your boot parameters, type:

nvram -xp

Look for the "boot-args" field (which may not be there, in which case you aren't booting into Safe Mode) and if you have any of these listed, it means:

  1. -v boot verbose
  2. -x boot into Safe mode
  3. -s boot into Single-user mode (like an enhanced safe mode, used for low-level filesystem manipulation / repairs / investigation / etc
  4. -k boot without kernel extensions (if you have corrupted kexts, they should be rebuilt cleanly)
  5. -K boot without kernel cache (same deal re: corrupted cache)

You can add any of these to your nvram settings if you wish, and they'll be persistent (until you remove or adjust them) - this example below would boot you into Safe Mode with Verbose output indefinitely:

nvram boot-args="-x -v"

By design, you can safely clear your entire nvram settings and the system should rebuild upon next boot. To clear your nvram on the command line, type:

nvram -c

As for OS X recognising your drives, there is so much more information available using the Terminal. The diskutil command is very easy to use and has simple, clear instructions and output. Type something like:

diskutil list 

and you'll see all disks / drives / partitions (mounted and unmounted) listed.

To see all your mounted filesystems (and their mount-points), simply type:

mount 

You can mount your EFI system partition by creating a directory to use as a mountpoint:

mkdir /Volumes/EFI

then mount the 'hidden' system partition

mount_msdos /dev/disk0s1 /Volumes/EFI 

or

mount -t vfat -o rw /dev/disk0s1 /Volumes/EFI

(-t is the filesystem, -o denotes mount params [rw is read/write, use ro for readonly])

and to unmount

umount -f /Volumes/EFI

diskutil and hdiutil commands give you a lot of information which will almost certainly give you enough information to work out what's wrong with the unmountable drive.

7
  • Check the formatting options please, # creates headlines. You need to indent code by 4 spaces.
    – slhck
    Mar 15, 2012 at 12:04
  • Thanks, I will endeavour to do it properly (I was mistakenly copying the formatting of another poster but your advice is superior ta) - of course, it's redundant as my account has banned from providing answers. No reasons given. One assumes for the crime of "helping people", banned by someone who doesn't want people to be helped?
    – jonny
    Mar 15, 2012 at 13:08
  • I'll take a wild guess and say it's not because you were trying to help (obviously, we encourage that), but the way you formulated these answers. I gave you some tips on that already, also see the edit history on this very post.
    – slhck
    Mar 15, 2012 at 13:16
  • I can't wish a guy "good luck"? As for the whole "if you have nothing nice to say, then don't be honest" policy being subscribed to; I'm unable to credit such ill-advised 'logic' as being helpful to anyone. This is a world where some things aren't nice and the reason they continue to not be nice is because people think it's rude to be honest about things which are not nice. Personally, I couldn't care less about the feelings of those who are responsible for dysfunctional software. I care about Truth, and I never lie. If shown to be wrong, I will rush the correction.
    – jonny
    Mar 15, 2012 at 16:53
  • That's not the issue. How is "this is crap" the truth? If you can factually prove that something doesn't work as expected (always related to the actual question you're answering), then fine. Running around cursing though isn't helping anybody. It's not about "hurting the feelings" of someone. You just come off as insulting and unprofessional, sorry. You've been told that already, and I won't repeat myself. If you need any further guidance about etiquette here, please ask a question on Meta Super User.
    – slhck
    Mar 15, 2012 at 20:01
0

some drives require that a utility provided by the manufacturer be installed on the system to authenticate the user; this should only be the case if you used said utility to encrypt or otherwise password protect the drive.

2
  • This isn't the case here, unfortunately, as there was never any encryption or password-protection.
    – modulaaron
    Feb 13, 2012 at 7:33
  • additional details might help the community provide you an answer. e.g. did this drive ever mount properly on the mac? brand / model? will it mount on a different computer / OS? have you tried using utlities provided by the manufacturer to mount the drive?
    – obsd
    Feb 13, 2012 at 18:33
0

I've just experienced a similar problem. I have a WD 2TB dual drive, which suddenly wouldn't mount. I could see it in the System Profiler, but it was greyed out in Disk Utility. The problem wasn't the ports or the cable, and repairing the disk via Disk Utility wasn't working.

But Disk Warrior fixed it.

DiskWarrior recovers your files including your photos, music and videos. DiskWarrior cures those cryptic errors reported by Disk Utility. DiskWarrior uses a different approach to disk directory repair than other programs.

0

When my drive was showing this behavior I tried many of these technical suggestions and others on many machines with differing operating systems. Nothing worked.

I then unplugged the drive's power cord and plugged it back in. That did it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .