OS: Windows 7 x64

Fingerprint reader: Validity VFS300

Fingerprint software: DigitalPersonaFingerprintReader 5.20.230

Here's an image of the icon that I wish to remove:


Note that this icon only appears when viewing the control panel list from the Start menu... it does not show up in the control panel folder. If I right-click the icon and choose "Create shortcut" I get the message "Windows could not create the shortcut. Check to see if the disk is full." although there is plenty of space on the disk.

I believe that the icon is actually for the "Biometric" control panel. Recently I installed my Fingerprint reader driver and software (both latest versions) and this should have enabled the Biometric control panel. I tried uninstalling and re-installing both the driver and software but it has not removed this blank icon. Note that the fingerprint reader does function perfectly.

My next step was to try removing the registry entry for the control panel (which was located at: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace\{GUID here}) but when trying to delete the entry (even in safe mode) I get the error: "Cannot delete {GUID here}: Error while deleting key".

I also tried removing the control panel by moving the "biocpl.dll" file out of the system32 directory but it seems that that file must stay there as it's a part of Windows.

Any ideas on how I can get rid of this icon?

  • This icon/item is still there and I'm not sure what I can try as a next step. Does anyone have any suggestions? – Coder6841 Feb 15 '12 at 16:28

I had the same blank icon and resolved the issue by upgrading the intel proset/wireless drivers to the latest - 15 version from intel. For me it had nothing to do with the "Biometrics" entry in the registry. If installing the new drivers using the recommended installation doesn't solve the problem try installing again, doing a custom install and add the crossed out optional components. Hope this helps.

  • Thank you very much Mike! That did it. I had incorrectly associated the Biometrics stuff with this issue. Upgrading from to 15.1.1 resolved the issue. – Coder6841 May 27 '12 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.