I have a Windows 7 laptop, which i am fixing for a friend. There is no connectivity at all. I have tried several interfaces - Ethernet, WLAN, Mac OSX internet sharing over ethernet.

Internet Explorer diagnostics reveal that The DNS server is not responding, I am using OpenDNS for name resolution. I have read about a potential Windows 7 WinSock problem, supposedly resolved by issuing

netsh winsock reset catalog and
netsh int ip reset reset.log hit

However for each of these commands, I receive an error: The helper DLL WSHELPER.DLL could not be loaded.

I have tried several ways to register the DLL but each time it reports it cannot be found, even though it exists in System32, System64 and SysWOW64. I have tried:

regsvr32 wshelper.dll and
netsh add helper wshelper.dll

How can I restore connectivity?


  • Are the devices detected and do they have the needed drivers? What were you fixing originally? – Dave M Feb 14 '12 at 15:01
  • Were you able to resolve this? I'm having a similar issue. – Shane May 10 '12 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.