When I create a folder or copy files, after the operation finishes I have to manually refresh the Explorer window (F5). For example, when I create a folder, I don't see the "New Folder" until I hit F5.

Does anyone have any idea how to fix this?

  • 3
    I have noticed this behavior, and it always goes away after a restart. I have never heard of it persisting after a restart, and I would be interested to hear from anyone who has the problem persist after a restart. For me it kicks in after only a couple of days without a restart. And I have done a fresh wipe and re-install only 3 months ago. Please let me know if restart fixes problem.
    – Almeister9
    Jun 3, 2013 at 6:42
  • 4
    same thing happens after a restart
    – Remus Rigo
    Jun 20, 2013 at 4:05
  • 1
    Seems like restarting is a working solution (changing Explorer|Search didn't work).
    – mins
    Jun 20, 2015 at 12:31
  • 1
    There's this article that summarizes many of the known possible fixes to the problem. I am not making this a full answer as this will require me to write a synopsis of that article: itworld.com/article/2827156/windows/…
    – ysap
    Oct 2, 2015 at 12:38
  • 1
    Even killing all the explorer.exe processes and restarting explorer doesn't seem to work Jul 31, 2016 at 5:51

16 Answers 16


Here is an incredibly simple solution that worked for me. It may work for you as well:

  • In Windows Explorer: choose Tools, Folder Options > Click the Search tab > Check or uncheck ANY option
  • Apply.
  • If this solves your problem, you can revert to your original setting and the problem will remain solved.

For Windows 10, the folder option is updated to View -> Option in Windows Explorer

  • 23
    Folder Options -> Search tab -> cannot find the "ANY" option :\
    – chwi
    Jan 28, 2014 at 8:06
  • 2
    I think you mean "go to Control Panel to choose Tools..." as well as "check and then uncheck any option".
    – Rob
    Feb 15, 2014 at 23:20
  • 4
    This worked only until reboot for me. The culprit was a stored not anymore existing FTP-connection
    – Thorben
    Dec 29, 2014 at 11:36
  • 1
    Wow - this works. ANy way to get it to persist after a restart? Jan 14, 2016 at 17:46
  • 1
    Astonishing! Seems to really work (on Windows 10), I wonder how long till it stops working again. Mar 16, 2016 at 9:37

Refer to Windows 7 does not refresh folder views on Microsoft Answers and Windows Explorer doesn't refresh when moving/deleting. Several posters stated that the issue pertains to the Windows UI Shell and several solutions exist:

  • Remove a "Network Connection" that points to a server that is not currently available.
  • Disable the Client for Microsoft Networks in properties of Local Area Connection.
  • Or simply going through Control Panel -> Folder Options -> View, then click 'Reset Folders'.

Let me know if these links help you out!

  • @RemusRigo You're very welcome.
    – Rob
    Feb 19, 2012 at 14:49
  • i'm back at work and it still doesn't refresh :(
    – Remus Rigo
    Feb 21, 2012 at 11:45
  • Reset Folders wasn't available for me (was greyed out) until I started when I was on the C: drive, not a subdirectory. Dec 26, 2012 at 23:28
  • @thursdaysgeek Sorry, updated the answer... a year and two months later.
    – Rob
    Feb 15, 2014 at 23:24
  • 4
    Good answer. For me it was the not existing network resource
    – Thorben
    Dec 29, 2014 at 11:40

A solution that worked for me: I found that none of the steps advised above (or on other sites) was working. However, the folder I was working in was part of a "Library." I found that if I switch to working in the original file location, I no longer have the problem. It seems that there's a bug with Windows updating views within libraries.

More details: I was trying to work in Libraries\Dissertation Research, which includes several folders located on various drives. I switched to working in D:\Dropbox\Academia\Dissertation. Problem solved.

Hope this helps someone else.

  • Thank you, this worked for me. None of the other solutions above had solved it. My "My Documents" folder is on a non-standard location, on a different disk. Feb 14, 2021 at 0:46

This is my experience: A zombie network-share folder triggered this problem. After I delete that zombie(the X1500 yellow stuff below), auto-refresh works again immediately.

enter image description here

The proposed "Folder Options > Click the Search tab > Check or uncheck ANY option" workaround is effective for me, but it works only for current Explorer window, so closing and reopening one will bring back the bug.


One way to circumvent the issue is to use an alternative file browser, such as Explorer++ (free). The latter is not affected by the auto-refresh issue, and has a few interesting features such as tabs.

  • 2
    Thanks, but I don't want to use alternatives, I want to fix Windows Explorer
    – Remus Rigo
    Nov 8, 2013 at 15:45
  • Another problem using a 3rd part explorer, is the file-browser dialog box, used by application (e.g. Office) will not use the new 3rd part browser.
    – MrCalvin
    Dec 14, 2019 at 9:52

The problem for me was a "Libraries" linking problem. I could delete with folder update in my User folders, but no refresh when deleting in the Libraries folders.

Right click on each major folder in Libraries, then Properties, be sure proper type of optimization is selected (Documents, Music, etc.), Restore Defaults, Apply. Delete then updates in the Libraries folders.

I think it rediscovers the folders in their real location on the hard drive and resets that connection with all the proper options restored.


Found something that works for me. Open the registry:


and set the value of DontRefresh (REG_DWORD) key to 0.

Note: If you have a 64 bit windows (x64), the registry is:


Also, If you do not see it, you will have to create the path by right-clicking and selecting New at each level.

  • Just curious, how has this been working out for you?
    – Rob
    Feb 22, 2012 at 23:51
  • hmm.. worked fine for a short time, the next day at work I got the same problem
    – Remus Rigo
    Feb 23, 2012 at 14:06
  • i wish that i could reinstall OS, but that is not a serious problem and my colleagues didn't complain...
    – Remus Rigo
    Feb 23, 2012 at 14:08
  • 1
    That key, {BDEADE7F-C265-11D0-BCED-00A0C90AB50F}, does not exist for me. Copied and pasted it into Find, and no results were found. Aug 24, 2015 at 13:58
  • search for DontRefresh. That worked once for me. Now I have the problem for third time and I tried all the things I tried before including deleting and recreating this registry value - didn't work this time
    – NickSoft
    Jun 7, 2017 at 21:36

If nothing else works restart explorer:

Open Task Manager >> Processes Tab >> find Windows Explorer >> right click >> Restart.

Take note this will lose all opened Explorer windows.


OK I was able to solve the issue (In my case), I went to "properties of Local Area Connection" I only had IPV4 checked, so I checked "Client for Microsoft Networks" problem rectified immediately !!


I'm a little late to this party, but making the following registry change fixed my Explorer update problem with no reboot:

Open regedit.exe and create this key:


Then create this dword value:


Close regedit and test. Worked for me on Windows 7 Pro 64bit.


Fixed my shared Network Directory Tree refresh issues by adjusting the Windows LAN Manager Server registry parameter IRPStackSize. Increasing the value of that parameter resolved refresh issues on deleted and moved file entries.

  1. Open RegEdit
  2. HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
  3. Find the key "IRPStackSize"
    • Increase the value to 30.
    • Add a new DWORD Value with the value of Decimal 30 if missing
  4. Reboot

Source: this Microsoft Answer post.

  • Please edit your answer and put the essential information here as well. I started doing that but do not understand what you mean with 'sar menu' in your answer there.
    – Jan Doggen
    Dec 8, 2014 at 7:59

None of the solutions worked for me. After two years, I finally solved it:

Link Shell Extension was causing the issues.

After uninstall (choco uninstall linkshellextension), the problems were gone.


I found that disabling Client for Microsoft Networks in properties of Local Area Connection worked for me and then I re-enabled it and the problem is still gone...


This fixed it for me:

Open explorer --> right click on Documents --> in the documents library pane click the Restore Defaults button --> click Apply Problem solved :)


Right click the problem folder to go to folder properties and then click restore defaults.

It's caused by a registry key that can be checked to stop the folder from auto refreshing. This can be checked/unchecked by by processes running but not through the gui.


Client for Microsoft Windows was disabled. I enabled it.

Then I restarted Explorer by executing a bat file with this in it:

taskkill /f /fi "imagename eq explorer.exe"
START explorer.exe

Not the answer you're looking for? Browse other questions tagged or ask your own question.