5

I can connect to a hotel or library wireless network using the standard Windows 7 WiFi connection and I can acquire the IP address. However when I start a web browser session I'm unable to see the hotel or library login screen. The login screen where you put in a code of some sort on a ticket that they give you and you continue.

In one place I was able to go to the gateway IP address directly and continue. However other place that tactic doesn't work.

This behavior is the same for IE, FF and Chrome. Windows 7. It started doing this a while back and I can't recall what setting, if any, I would've changed back then.

My Kobo Vox Android tablet has no problems seeing the login screens in it's browser so it's something in my laptop.

5
  • 2
    Did you check your DHCP- and proxy-settings?
    – Tom
    Feb 15, 2012 at 8:19
  • So what I'm I supposed to check for? And where? The WiFi adapter? Hmmmm, I did have the DNS set to Google 8.8.8.8 due to some problems a while back. That could be related. I've removed that and let it use the default. The DHCP settings on the WiFi are defaults. There are no proxy settings present on the Internet Options tab in IE.
    – Tony Toews
    Feb 15, 2012 at 18:24
  • 1
    A captive portal usually works with DHCP and DNS. So Google-DNS might not know the hostname of the captive portal, which leads to an error. No hostnames and DNS are involved when browsing to an IP-address; so this worked. Setting the wireless connection to DHCP(yeah, also DNS) should work. When you want to use another DNS in your home-network, you should consider setting it on the access-point or router and not your local connection.
    – Tom
    Feb 16, 2012 at 7:39
  • Tom, yes, I was thinking on that after I made the change. And yes the equipment would have to start by rerouting all DNS traffic to it's own server before letting you log in. So that would make a lot of sense. Learn something new every week or so. Anyhow I start a road trip in the next hour or so so will confirm this worked this evening.
    – Tony Toews
    Feb 16, 2012 at 19:04
  • 1
    Tom, removing the DNS entry fixed the problem. Thanks for suggesting the area to look at.
    – Tony Toews
    Feb 18, 2012 at 18:05

6 Answers 6

4

Thanks to Tom for pointing me in the right direction. I had added a DNS entry due to some DNS issues a while back. Removing that solved the problem. Here's what Tom said:

A captive portal usually works with DHCP and DNS. So Google-DNS might not know the hostname of the captive portal, which leads to an error. No hostnames and DNS are involved when browsing to an IP-address; so this worked. Setting the wireless connection to DHCP(yeah, also DNS) should work. When you want to use another DNS in your home-network, you should consider setting it on the access-point or router and not your local connection. – Tom 2 days ago

3

In the START menu, type:

IPCONFIG /RELEASE

press enter and then type:

IPCONFIG /RENEW

Reload the page now and the issue should be resolved.

Viola.

1

Sometimes with corporate login screen that appear in your browser, you'll first have to navigate to some website like www.google.com or www.facebook.com. The hotel/library wireless service will intercept this request and present you the login screen.

Hope this helps. (I experienced this with my school login and also the public WiFi login in my place.)

4
  • Yes, but it's been my experience that as soon as you attempt to open any page that the WiFi security device intercepts that request and forces you to login. That isn't happening now.
    – Tony Toews
    Feb 15, 2012 at 17:51
  • I've noticed before that sometimes it only works on the root url like www.google.com but not on a page url like www.google.com/some-page.html. Could you try that?
    – ADTC
    Feb 18, 2012 at 7:46
  • Removing the DNS entry fixed the problem.
    – Tony Toews
    Feb 18, 2012 at 18:06
  • That's great! I didn't know about the DNS thing. Glad it all worked out for you.
    – ADTC
    Feb 19, 2012 at 1:22
1

Try browsing to the root url for the hotel gateway. Usually you will have a paper or other guide that includes the hotel name, etc, in a url that doesn't work. Example: SSID is EastsideCannery.rooms-cox (doesn't work manually) root here is cox.com Just enter cox.com and the gateway pops up. Also not all gateways are happy with all browsers. Keep a shortcut/alias for a browser in no-extension mode.

0

Type IPCONFIG in the Start menu, note the IP address in Default gateway line, and type this into your browser and hit go.

Worked for me.

2
  • The OP says he has tried that. And if you type ipconfig in the start menu, all you get is a flash of black screen.
    – user477799
    Mar 1, 2017 at 11:58
  • Perhaps, but this solution also worked for me at Holiday Inn Express (IHG) just now. Rather than just dump on him, you could also add: be sure to run the command in the command prompt.
    – JohnL4
    Aug 4, 2017 at 14:34
0

I just restarted my Windows a couple times and it worked. That's what has worked in the past.

None of the other answers worked for me on Windows 10.

(Perhaps, this restarting was involved with the other "answers". Post hoc ergo propter hoc.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.