I can SSH into remote server just fine using private key authentication with prompt for passphrase.

However I'm getting permission denied when I try to SCP a file using the same passphrase. Here's my output:

$ scp -v [file] [user]@[remoteserver.com]:/home/[my dir]

Executing: program /usr/bin/ssh host [remoteserver.com], user [user], command scp -v -t /home/[my dir]
OpenSSH_5.3p1 Debian-3ubuntu7, OpenSSL 0.9.8k 25 Mar 2009
debug1: Reading configuration data /home/[my dir].ssh/config
debug1: Applying options for [remoteserver.com]
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to [remoteserver.com] [[remoteserver.com]] port 22.
debug1: Connection established.
debug1: identity file /home/[user]/.ssh/aws_corp type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3p1 Debian-3ubuntu7
debug1: match: OpenSSH_5.3p1 Debian-3ubuntu7 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.3p1 Debian-3ubuntu7
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '[remoteserver.com]' is known and matches the RSA host key.
debug1: Found key in /home/[my dir]/.ssh/known_hosts:12
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/[my dir]/.ssh/aws_corp
debug1: PEM_read_PrivateKey failed
debug1: read PEM private key done: type <unknown>
Enter passphrase for key '/home/[my dir]/.ssh/aws_corp': 

debug1: read PEM private key done: type RSA
Connection closed by [remote server]
lost connection

I've searched for answers but can't find quite the same problem or am just being thick. Either way any help is much appreciated. Cheers!

  • can u get the /etc/ssh/.sshd_config from the server ? – user218473 Apr 20 '13 at 9:19

Your scp does not say "permission denied" anywhere. It just says "Connection closed", which might mean that the server is missing a scp command, or failing to start it for some reason.

  • Try ssh [user]@[remoteserver.com] scp. If it says "usage: scp ...", then scp is okay. If it says "command not found", then...

  • If you have admin access on the remote server, check the logs there; maybe even start sshd -rdddp 222 in debug logging mode.

  • Thanks for your help. That didn't work but I finally tracked it down to directory permissions on the remote server - I'd loosened them whilst digging around and tightened them again - voila. – ArtfulDodger2012 Feb 15 '12 at 11:47
  • @ArtfulDodger2012 Answer your question yourself please, you can do this in a couple of hours. – slhck Feb 15 '12 at 12:27

I had this problem. In my case, when I tried running scp on the server (chroot jailed), I got the unknown user error. To fix this:

Please note <jail> in the code below is the full path to the chrooted jail filesystem you created for the ssh session login.

sudo cp -vf /usr/bin/strace <jail>/bin
ldd <jail>/bin/strace
sudo cp -vf ...

Do the copy for each of the missing libraries from the main system to the <jail>/lib64 directory

In a chroot jailed session run:

strace scp

Copy over the library/libraries it fails to find per the output to the /lib64 directory using -vf option. In my case, it needed me to copy over libnss_compat.so.2

After that scp in the chrooted jail worked!

  • But... there is no chroot jail in OP question..? – 174140 Aug 7 '19 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.