6

I am running Ubuntu Server 10.04 (lucid lynx), and I just purchased a hot-swap compatible hdd bay and installed it. When I insert a hot-swappable SATA drive, the drive does not show up after running ls /dev/sd?. If I reboot the server, then after it comes back up the drive appears. I have checked /var/log/messages and nothing shows up when I insert the drive, only after rebooting.

I have tried the following:

$ sudo echo "0 0 0" > /sys/class/scsi_host/host4/scan
$ sudo partprobe`
$ sudo udevadm trigger

Every answer I've found searching Google was one of the things I listed in "I have tried..." and I don't really know what to do at this point. Does anyone know why this occurring?

5

This turned out to be a face-palm moment for me. I was sure I had AHCI turned on in the BIOS settings. Looks like I was wrong. After I turned on AHCI, hot swapping worked like a charm!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.