4

I tried following the procedure outlined in this previous answer and it doesn't work: https://superuser.com/a/5079/2366

Specifically I'm trying to add Lucida Sans Typewriter Regular to the choices of Consolas and Lucida Console that the Cmd window currently allows. Lucida Console is in registry key "0" and Consolas is in registry key "00", so I'm adding key "000" but it's not affecting the available choices in the Font tab under Properties, even after rebooting the system.

P.S. I also tried adding Courier New to the choices and it shows up, but appears to select Italic instead.

11
  • You sure it is a raster font? "Before doing any of this, please read the article "Why are console windows limited to Lucida Console and raster fonts?", which explains in great detail why you shouldn't do that anyway." Commented Feb 17, 2012 at 8:47
  • @OliverSalzburg, no it's not a raster font - it's TrueType. The article merely explains why the window will be ugly, not why the workaround won't show the font at all. Commented Feb 17, 2012 at 14:39
  • The font has to be monotype. In other words, they all have to be the same size. II WW not monotype. :(
    – Roke
    Commented Oct 25, 2015 at 21:30
  • @RookieTEC9 the font I was attempting is monospace ( not Monotype, that's a brand). Commented Oct 25, 2015 at 23:53
  • I meant monospace sorry for the confusion.
    – Roke
    Commented Oct 25, 2015 at 23:56

3 Answers 3

5

As well as the list of steps you linked to, This article lists some further restrictions.

To test that things are working, you should be able to do this (I did, in Win7 64-bit):

  1. Go to

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Console\TrueTypeFont
    
  2. Add a string entry 000 with value Courier New

  3. Close the CMD windows and open a new one. (If you do not do this, the font appears in the Properties > Fonts list but does not actually work when clicked).

If you use a font that does not meet the criteria, it just won't appear, which is frustrating. Here are the restrictions repeated from the MS support article:

The fonts must meet the following criteria to be available in a command session window:

  • The font must be a fixed-pitch font.
  • The font cannot be an italic font.
  • The font cannot have a negative A or C space.
  • If it is a TrueType font, it must be FF_MODERN.
  • If it is not a TrueType font, it must be OEM_CHARSET.

Additional criteria for Asian installations:

  • If it is not a TrueType font, the face name must be "Terminal."
  • If it is an Asian TrueType font, it must also be an Asian character set.

[...]

The name needs to be incremented with 0 for each additional font. The Data entry needs to match the font’s entry in the following registry location:

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts

I found that the DejaVu Sans Mono font worked, and that font has a wider range of unicode characters than Consolas, Lucida Console, or Courier New.

2

You may try ConEmu - Windows console emulator. I'm the author of this program.

It allows you select any font, even proportional.

Moreover, you not obliged to install font into the OS, just copy font (*.fon, *.ttf, *.bdf) file to ConEmu directory and restart the program.

0
0

Well for starters,

  1. Lucida Sans TypeWriter Regular should be Lucida Sans TypeWriter
  2. Instead of modifying String Values 00 and 0 just leave them as they are and add new strings.

Your final should look sorta like this: (Just note that I have 0 filled in as monofur, this neat font I download for free) enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .