Here is a challenge: how is this done? I've tried disabling the ASM1061 controller in the Onboard Devices section, using Wubi, booting from USB (as I don't have a DVD drive, yet), and even booting from RAID/IDE (with AHCI as the default) to do this. Still, no dice.

Google shows up virtually nothing related about Linux and this mobo, apart from a people just saying "disable ASMedia" (which, I assume is the ASM1061 controller, as that's all I see - apart from the USB 3.0, which I disabled already) and it hasn't really helped much.

Thus, what is wrong here?


My problem is that I cannot boot Linux via USB or a simple Windows installer such as Wubi (for Ubuntu).

I wind up getting error messages along the lines of write cache failed, along with many other cryptic error messages similar to the following:

[ 1400.351374] sd 4:0:0:0: [sdb] Test WP failed, assume Write Enabled
[ 1400.353433] sd 4:0:0:0: [sdb] Asking for cache data failed
[ 1400.356601] sd 4:0:0:0: [sdb] Assuming drive cache: write through 

This seems to be common for Asus P8Z68-M Pro motherboards, with the only notable solution being to "disable ASMedia", which, as I said before, I'm guessing is the ASM1061 controller on the motherboard. Despite already disabling this, I have tried this with both Fedora and Ubuntu without any success.

I need to know what I can do about this; has anyone ran into something similar or heard about this issue before? I know these motherboards are relatively new...

  • "Thus, what is wrong here?" How should we know? you are not desribing your problem with one word... – Baarn Feb 19 '12 at 2:29
  • Sorry; I edited the question for clarity. – Holland Feb 19 '12 at 5:24

I bought this mobo last week and had similar problems. I initially tried Centos 6.2 x64 LiveDVD and it would hang on the second splashscreen (black, usually with revolving circle indicating OS loading).

I tried Scientific Linux 6.2, Centos 6.2 Minimal, 32-bit versions, and then finally Ubuntu 11.10 Desktop 64bit which did work, and was able to install fully.

I need Centos to study for Red Hat certs so the Ubuntu install was mainly so to have a linux with which to probe and get more info for comparative diagnosis, which I didn't get around to as I was trying to profile the different installer discs to see which would work and compare the differences.

While burning off some more distros I took a different path by methodically working through the BIOS and it turns out that disabling the ASMedia 1061 did work for me, I'm now able to boot into the Centos Live enviroment and install to the harddrives.

A few more things I came across: -this motherboard has a UEFI bios, and at least Red Hat (which Centos and Scientific Linux is built on) has specifically noted that UEFI is only supported on 64-bit builds of their distro. (May be relevant if Wubi is 32bit?) -RH/Centos/SL 6.2 is built with kernel ~2.6.x where the Ubuntu 11.10 LiveDVD has a 3.0.x kernel. Might point to driver availability at time of kernel build.

I've downloaded Fedora 16 but hadn't burned to disc and tried it before turning off EVERY bios setting and laboriously turning them on a couple at a time and rebooting to see if it would work...

I hope this all helps in some way.

  • IT does! Thank you - this has given me much insight. It looks like this motherboard is just too new to handle some of the more modern distros of today. I actually disabled ASMedia 1061 as well, but that didn't help with booting off of usb. I'll probably know more as soon as I get a DVD drive for this box though (and I'll be sure to report my results here). – Holland Feb 20 '12 at 20:11
  • I'll be interested to see how Fedora boots, it's usually well ahead on featuures, don't know about drivers. RedHat and derivatives are well behind on hardware support and the bells and whistles, in favour of stability and enterprise-y-ness. The ASmedia 1061 is actually not a new chipset (google shows newegg sales and other reviews from at least 12months ago) so I'm not sure why this hasn't made it in... but I don't really understand how these decisions are made anyway. Probably based on popularity and what the maintainers have on hand (scratching their own itch, etc) – bdp Feb 20 '12 at 23:47

I installed on P8Z68-M PRO Linux Mint-12 without any problems. Then new Linux Mint-12 KDE released and I decided to try it. Unfortunately it stuck during installation process every time I tried (for 2 or 3 times). Both tries I did from USB stick made bootable by unetbootin utility. Finally I installed Linux Mint-12 back. But now it seems there is a problem with network adapter driver. It seems to work fine but sometime it suddenly drops down the connection. The same box works perfectly under Windows-7

  • Hmm...I'll be sure to try that tonight if possible. – Holland Feb 21 '12 at 0:02

For some reason, the only two distros I've been able to get working with this have been Sabayon and Arch Linux (ArchBang, specifically). I haven't tried Gentoo (though, since Sabayon is a Gentoo deriviative I'd imagine it would work), but it seems that the pattern here has to deal with rolling releases which typically throw the latest version of the kernel into their release. Why it is this way, I have no idea.

Hope this helps for anyone in the same situation.


Download & install Oracle VM VirtualBox Open Source the VirtualBox-4.1.18.tar.bz2

followed by


when installed correctly, you will be able to install centos or scientific linux. These are great servers, but they need to get with the program so they can be installed on the power pc!

  • The OP cannot install an OS, therefore cannot install a VM either. – terdon Oct 11 '12 at 23:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.