Recently, I've been having problems connecting to a remote machine via RDP. I can connect fine exactly once, but all subsequent attempts fail until the remote machine is rebooted. I seem to authenticate properly, but the RDP logon dialog disappears after showing, "Configuring remote session..." for a few seconds. No errors or other useful info is written either to my screen or the Event Logs of the two machines involved. I've tried disabling remote sound as others have suggested, with no success.

I'm still investigating a solution, but would appreciate any thoughts. Fortunately, I can reboot the box remotely w/o causing any problems, but this is a less than ideal workaround.

  • Have you tried closing the connection differently? Also do you have physical access to the machine and have you tried logging in locally after the RDP session? – MBraedley Feb 20 '12 at 22:05
  • Yes, I've tried just X-ing out of the RDP session as well as start-> disconnect. And yep, I've been able to log in locally after an unsuccessful RDP attempt. – Duane Mar 13 '12 at 23:06
  • When the problem occurs again - and you have some folders being shared from the remote computer also - can you please try and connect to these with the same username/password and let us know if this works or not? – Steve Rathbone Jun 14 '12 at 9:59
  • It might be worth trying to rdp in with a new, temp user account and see if this works or not also... – Steve Rathbone Jun 14 '12 at 10:02
  • 1
    Maybe remote computer goes into hibernate mode? – Ishikawa Yoshi Jul 30 '12 at 7:26

Can you check the event log of the machine to which you are trying to connect? It should contain a error for RDP. I had faced the same issue recently. It was due to a Microsoft patch which was overwritten by Windows 7 SP1. (Basically the patch which was of higher version was installed before SP1 by Windows Update.)

FIX: Uninstall KB2667402 and re-install it. See this post for details.

After you install security update 2667402 on a computer that is running Windows 7 or Windows Server 2008 R2, and then you install Service Pack 1 (SP1) for Windows 7 or for Windows Server 2008 R2, the binary version of Rdpcorekmts.dll is 6.1.7600.16952 and not 6.1.7601.17767. In this scenario, you may be unable to create a remote desktop session to control the Windows 7-based or Windows Server 2008 R2-based computer.

This issue occurs because the SP1 binary version of Rdpcorekmts.dll was not originally deployed when security update 2667402 was originally installed.

I had the same issue. The computer I was trying to login to had Windows 7 Home Premium on it, which does not have Remote Desktop server-side support. I suspect that I had used a hack to enable it, then installed Service Pack 1, which broke the hack.

This article (and I'm sure there are others), has instructions with a supporting file to restore the hack for SP1.

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.