Eclipse is showing an odd short menu in place of the normal one when I right-click on a project (or anywhere) in the Package Explorer pane in Eclipse 3.7.1.

Normally I see a big context menu with a boatload of options, including "New", "Copy", "Paste", "Import", "Export", "Run as" etc. A few hours ago, something changed and now a right click brings up only the menu shown in the attached image.

Of course, "it used to work fine" - I didn't upgrade Eclipse, monkey with user preferences, or do anything else that might explain this. Maybe I (or the cat) clicked something accidentally.

How to get rid of this menu, and what is it for anyway?Strange new context menu in Eclipse Package Explorer

  • Have you tried to uninstall, delete folders, and reinstall? – harrymc Feb 27 '12 at 8:57

I would prefer to comment instead of answering, because I'm not sure my answer is correct as I'm not able to reproduce the issue.

Anyway, I suggest you make sure you choose the correct perspective

Window->Open Perspective

And then try to reset the perspective:

Window->Reset Perspective
  • @darenw, Can you confirm if this worked for you or not? – zenpoy Mar 4 '12 at 11:44
  • That wasn't it. The problem did go away eventually, after I accidently clicked something else. – DarenW Apr 18 '12 at 0:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.