I'm encountring some difficulties with my Apache2/PHP5. All was well-configured and working, but after reinstalling apache2, the PHP files are displayed without being interpreted.

I tried many workarounds like:

AddType application/x-httpd-php .php

in the httpd.conf file, but still get the same issue. Please note that httpd.conf was not changed.


Are you loading PHP Module ? In your httpd.conf, check :

LoadModule php5_module        libexec/apache2/libphp5.so

Of course, you must change module path, to where your libphp5.so is.

Furthermore, you also need your entry

AddType application/x-httpd-php .php

If you want to use indexes with .php, modify the dir_module condition :

<IfModule dir_module>
    DirectoryIndex index.html index.php

But before running all of that, you could run an apt-get :

 apt-get install libapache2-mod-php5
  • The last line is the important one. The package installer should have done all the detail work for you. If it didn't, try re-installing the package before manipulating the Apache configuration directly. – Der Hochstapler Feb 21 '12 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.