Hopefully a simple question to answer.

I've built an XP Embedded image, and it takes from between 17 and 25 seconds for me to resolve to an IP when I ping google.com. Once it gets the IP address, the pings are just fine.

If I ping the IP directly it works just fine. Finally, if I use nslookup, I get a response back instantly.

This machine has 2 NICs, and I've tried disabling that which wasn't used, and have also tried disabling IPv6.

Many thanks for any help in advance!

Update: When I type nslookup at the command prompt, I get the following welcome message:

DNS request timed out.
    timeout was 2 seconds.
*** Can't find server name for address Timed out
*** Default servers are not available
Default Server:  UnKnown
  • 1
    See if using a different DNS works (Like the Public Google DNS server: – BloodPhilia Feb 21 '12 at 17:14
  • I think you're onto something, as it fixes it. I've updated my original post with a useful comment regarding a response I get from nslookup. Many thanks. – bduncanj Feb 21 '12 at 18:18
  • Can you post the output of ipconfig /all on the prompt without the Google DNS set? – BloodPhilia Feb 21 '12 at 18:43
  • I've pulled the box off my desk and am onto another project, but I've answered my own question (with your help) below). – bduncanj Feb 22 '12 at 19:46

On our local network the DNS server was not returning a reverse DNS entry for its own IP address. This slowed the first hop of the tracert down (to a delay of around 17 to 25 seconds).

BloodPhilia suggested trying Google's DNS server, which did have a reverse DNS entry for their own IP.

The problem was solved by uninstalling the IPv6 adapter (it had previously only been disabled).

|improve this answer|||||
  • Glad I could point you in the right direction (: – BloodPhilia Feb 22 '12 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.