I've got ESXi on my server and have couple of Guests on it. I have increased HD size of one the guests but when I boot into that guest - Win Server 2003 - it is not reflected. I know why. I need to boot that guest with gParted to re-size the partition. How do I do that if I connect to my ESXi with VMWare Infrastructure Client?

I have tried the following:

  • Properties of the Guest

  • CD/DVD Drive linked ISO of gParted with Devices Status Connected and Connect at power on checked off

but my Guest does not boot into gParted it just goes to Win Server 2003.

4 Answers 4


If you attached the GParted ISO as shown in the image below

enter image description here

and it didn't boot, you may need to change the boot order in the VM BIOS. The easiest way to get to the BIOS is to go to edit settings, select the "Options" tab, then highlight "BIOS Options". Check the box under "Force BIOS setup".

enter image description here

Once you're in BIOS, it's just like a normal PC, edit the boot devices and make sure the CD drive has priority over the hard disk.

  • Switching to the 32-bit i686 ISO ( gparted-live-0.29.0-1-i686.iso ) version of gparted and using "Force BIOS Setup" solved this for me! Aug 18, 2017 at 13:17
  • On Vmware workstation 15, use "Power on to firmware", then you will enter in the Phoenix Bios. From Bios change boot order, placing cdrom before harddrive Sep 5, 2019 at 18:13

The menu shown by Jim G is not showing on my 2015 VMware player.

I recently tried to boot from CD instead of HDD, I loaded an ISO and from HDD/CD "advanced" menu I set the order so CD is 0:1 and HDD was 1:0 but that didn't do the trick.

It kept booting from HDD, then I noticed the message press F2 to enter setup while booting, I was able to enter a bios system and set it to boot from CD there.

So look for a message like Press key X to enter bios.

  • VMWare Infrastructure Client and VMWare Player will have different options. You would usually download the Infrastructure Client by accessing your ESX Server and click on the link as shown HERE
    – Darius
    Aug 18, 2015 at 15:53

You mount the CD from either local ISO or from ISO image uploaded to ESXi( in vm preferences / cd-rom device)


My system is based on MacOS, so I needed to press and hold 'C' at the VMWare BIOS screen, much like a normal Mac.

My whole rigmarole is here in case someone else finds this article for the same reasons I found it:

I recently grew my MacPro VM's virtual disks from 128G to 256G, and ran 'sudo diskutil resizeVolume / R' to try to make the space available, but it told me 'MediaKit reports partition (map) too small'.

I downloaded gparted-live-0.27.0-1-i686.iso and put it into datastore1, added it 'at power up' to the VM's CD, changed the VM type to Other 2.6.x LInux 32 bit, booted the VM and held C down from the VMWare screen until it reached the GRUB screen, but while I could select the GRUB options, most of the resulting systems either didn't recognise the keyboard in character mode, or the mouse in GUI mode.

Every so often, the default GRUB option worked but while I got through language selection I found I needed to leave the GUI alone for quite a while - perhaps scanning the disk - before the it recognised the keyboard or mouse clicks.

I told it to fix the partition table - the 'do you want to fix this' that came up automatically.

I saw a small /dev/sda1, the EFI system partition, at 200M, /dev/sda2 the Mac HD, at 127G, /dev/sda3 the recovery HD at 620M, and 128G of unallocated space.

I asked to move the recovery partition to the very end of the free space, and it said that might be bad, so I just quit and rebooted.

I turned the guest OS back to Mac (I had to log in to the host as root to shut down the VM, for some reason: VMWare Fusion didn't give me the shutdown option), and now it's back in OSX.

Now resizeVolumes / R doesn't show the

'Note: Your partition map does not use the entire space of your whole-disk' warning, and completes without 'MediaKit reports partition map too small'.

And my HD is at 274G. not quite the whole 128G, but certainly better than 127.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .