3

I'm trying to install latest chrome on my RHEL 5.3.

[foo@bar Downloads]# rpm -ivh "google-chrome-stable_current_x86_64(4).rpm"
warning: google-chrome-stable_current_x86_64(4).rpm: Header V4 DSA signature: NOKEY, key ID 7fac5991
error: Failed dependencies:
        **lsb >= 4.0** is needed by google-chrome-stable-17.0.963.56-121963.x86_64
        libc.so.6(GLIBC_2.11)(64bit) is needed by google-chrome-stable-17.0.963.56-121963.x86_64
        libcurl.so.4()(64bit) is needed by google-chrome-stable-17.0.963.56-121963.x86_64
[foo@bar Downloads]# yum install lsb
epel                                                                                                                               | 3.4 kB     00:00     
2f36744c0ec6290ba30fc8af8e2d3b774cd1e443-primary.sqlite.bz2                                                                        | 3.7 MB     00:00     
google                                                                                                                             |  951 B     00:00     
primary.xml.gz                                                                                                                     | 3.2 kB     00:00     
google                                                         5/5
somecorp-linux-common                                                                                                                 | 1.1 kB     00:00     
primary.xml.gz                                                                                                                     | 5.2 kB     00:00     
somecorp-linux-common                                             17/17
vt                                                                                                                                 | 1.3 kB     00:00     
primary.xml.gz                                                                                                                     | 8.8 kB     00:00     
vt                                                             40/40
google64                                                                                                                           |  951 B     00:00     
.
.

Package **redhat-lsb-3.1-12.3.EL.x86_64** already installed and latest version
Package redhat-lsb-3.1-12.3.EL.i386 already installed and latest version
Nothing to do
[foo@bar Downloads]# 

====================

So, What should I be doing ? I'm ready to add a bounty to get the latest chrome on my box if I have to - (I'm frustrated).

Thank you,

1

As the error message says you are missing some dependencies to be able to run chrome. Your version of rhel needs to be upgraded to support that.

First upgrade your os yum update -y then try again.

  • 1
    This won't help, as the glibc in RHEL 5 is very old (glibc 2.5, while Chrome requires glibc 2.11 as per the error message). – Renan Feb 24 '12 at 0:22
  • Perhaps it would be possible to bastardise your system to allow for this version of glibc to be installed. – Dejan Feb 24 '12 at 3:03
  • while it's possible, I don't think this is a good idea, might result in other stuff breaking. – Renan Feb 24 '12 at 3:27
  • this is work computer -- don't want to break anything and end up having headaches when it comes to finishing my tasks. – anjanbacchu Mar 5 '12 at 8:07
1

You probably will not be able to run Chrome on RHEL 5, the glibc version in that distro is too old.

libc.so.6(GLIBC_2.11)(64bit) is needed by google-chrome-stable-17.0.963.56-121963.x86_64

But Wikipedia says RHEL 5 comes with glibc 2.5. A possible option is a Chromium build, though I have not tried it (just found it as an answer to a similar question).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.