Am trying to install cURL on my ubuntu server using the command

sudo apt-get install php5-curl

However i get the following error

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-curl: Depends: phpapi-20060613+lfs
Depends: php5-common (= 5.2.6.dfsg.1-3ubuntu4.5) but 5.3.2-0.dotdeb.1 is to be installed
E: Broken packages

I am running PHP Version 5.3.2-0.dotdeb.1 on my server. Whats the issue? I need to get curl up and running.

3 Answers 3


It looks like you have installed php5-common from the Dotdeb repository, but Dotdeb do not provide a php5-curl package. You either need to replace PHP with the version from the official Ubuntu repositories, or you need to build php5-curl yourself against the Dotdeb version.


It seems the package is broken in your source.

Maybe you can test this:

apt-get install curl


Firstly, you may want run this command sudo apt-get update

  • 2
    Could you expand your answer a little and tell us why this would solve the problem? Thanks!
    – slhck
    Aug 2, 2012 at 21:01
  • apt-get update refreshes your server's package list from the mirrors, ensuring you don't download old packages and that there are new inconsistencies in your package database. Dec 18, 2013 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.