33
☢ ☍ ⌘ ✰ ⣿ ⚡ ☯ ⚑  ↺  ⤴  ⤵ blabla

I need to display symbols above in Windows 7 using proportional fonts. However, some symbols are not properly displayed. This particular example is using Courier New.

damn it!

I have English(US) set in my regional settings.

Update:

The ultimate goal is to show in PuTTY this

enter image description here

As you can see on the left side there are many special chars.

Now see what I get with DejaVu Mono font.

DejaVu Mono

This one with Courier New

Courier New

This one with Consolas

Consolas

This one with Inconsolata

Inconsolata

This is test output with DejaVu Sans Mono.

enter image description here Click here to enlarge

Now compare those with the screenshot right below Update

13
  • Not all fonts support all symbols - are you looking for a proportional font with wide symbol support, or a way to get these characters in a particular font?
    – dsolimano
    Feb 25, 2012 at 3:16
  • @dsolimano: Proportional font with wide symbol support, because I need to see those symbols in Putty. Moreover, it has to be Unicode font.
    – Pablo
    Feb 25, 2012 at 3:19
  • I think you mean monospace not proportional (Courier New is a monospace font).
    – jhenninger
    Feb 25, 2012 at 3:27
  • Fixed width in other words )
    – Pablo
    Feb 25, 2012 at 3:38
  • I’m confused, why can’t you just use Courier New if it has the glyps you need?
    – Synetech
    Feb 25, 2012 at 4:19

4 Answers 4

11

Everson Mono works in PuTTY (a very important condition; many other fonts work, e.g. in konsole) for all the characters you posted. Doing a full test with the Python script, however, reveals a block that isn't quite right.

python -c 'print u"\u22c5 \u22c5\u22c5 \u201d \u2019 \u266f \u2622 \u260d \u2318 \u2730 " \
u"\u28ff \u26a1 \u262f \u2691 \u21ba \u2934 \u2935 \u2206 \u231a \u2240\u2207 \u2707 " \
u"\u26a0\xa0\u25d4 \u26a1\xa0\u21af \xbf \u2a02 \u2716 \u21e3 \u21e1  \u2801 \u2809 " \
u"\u280b \u281b \u281f \u283f \u287f \u28ff \u2639 \u2780 \u2781 \u2782 \u2783 \u2784 " \
u"\u2785 \u2786 \u2787 \u2788 \u2789 \u25b9\xa0\u254d \u25aa \u26af \u2692 \u25cc " \
u"\u21c5 \u21a1 \u219f \u229b \u267a ".encode("utf8")'

Everson Mono on PuTTY to a virtual Kubuntu machine

To use Everson Mono on PuTTY it may be necessary to tick the Allow selection of variable-pitch fonts box in Window -> Appearance -> Font settings section.

Other fonts, such as DejaVu Sans Mono, work perfectly in other programs, possibly borrowing glyphs from other files (I'm not sure how TT fonts work), which doesn't seem to work in PuTTY. Code2000 should have worked, but it did something... odd... to my PuTTY window. It may work for you. Every font I've tried works directly in konsole, even those that should not. It might be worth looking into an alternative client/emulator.

2
  • OK so far this one is closest, although some glyphses are very unclear even if I set font size to 16 and also cyrillic letters looks not proportional (one is bigger than another). But we are almost there. I would appreciate if someone can point to similar font which more looks like to inconsolate - clear and distinguishable even with small sizes. Thanks Bob, I will upvote your answer.
    – Pablo
    Feb 25, 2012 at 11:17
  • Anyway, I will accept your answer and repost another question with precise unicode font character ranges. I've tried all listed in Wiki, seems I need to find commercial one.
    – Pablo
    Feb 25, 2012 at 12:49
20

What you need to do is to set the font (Figure 1) and encoding (Figure 2) in PuTTY.

The font in your screenshot is Inconsolata (get the OTF file and copy it to your Windows Fonts folder). (PyroScope suggests DejaVu Sans Mono for Windows. Get dejavu-fonts-ttf-2.33.zip, extract the four DejaVuSansMono*.ttf files, and copy them to the Windows Fonts folder.)

The encoding to use is UTF-8.


Figure 1: Set the font:

PuTTY font set to Deja Vu Sans Mono

Figure 2: Set the encoding:

PuTTY encoding set to UTF-8

7
  • Which font exactly? I have tried both you mentioned, see my update.
    – Pablo
    Feb 25, 2012 at 4:31
  • with Inconsalata it's even more crippled, not even saying that Cyrillic chars are gone... see my update screenshot. Putty is set to UTF-8.
    – Pablo
    Feb 25, 2012 at 5:23
  • That's the problem... See my screenshot update.
    – Pablo
    Feb 25, 2012 at 5:40
  • 1
    Deja Vu Mono Sans + UTF-8 doesn’t work?
    – Synetech
    Feb 25, 2012 at 5:41
  • No it does not. Screenshot reflects python test output as per Pyroscope suggestion. Half of the symbols are crippled.
    – Pablo
    Feb 25, 2012 at 5:44
15

Update 2020

Suggest to install and use some patched fonts with basic emoji support, e.g., https://github.com/ryanoasis/nerd-fonts


I checked the accepted solution, however, on my machine, putty doesn't show Everson Mono or DejaVu Sans Mono in its font list. (There must have been something wrong with my system configuration).

Besides, I don't like to change my favorite monospaced font.

After some Googling, I found a more preferable solution:

Add (or Edit) an multi-string value for your preferred font under the Windows registry key

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink

The added (or edited) key name should be the font name, and the value associated is a list of fallback font options to display the characters not recognized by previous font. There should be some existing ones, you can copy the value from there.

For me, I added an entry:

Monaco -> 
    msyh.ttf,Microsoft YaHei Regular
    SIMSUN.TTC,SimSun
    MINGLIU.TTC,PMingLiU
    MSGOTHIC.TTC,MS UI Gothic
    BATANG.TTC,Batang

Reboot and now Putty is able to show the Unicode characters correctly:

oh-my-zsh prompt

3
  • You have to "Allow selection of variable pitch fonts". It doesn't recognize Everson Mono as monospace for some reason. Still doesn't show the characters correctly for me with that font, though.
    – endolith
    Aug 15, 2016 at 3:56
  • I had to reboot in order to get Windows 10 and PuTTY to display the fallback. YMMV. Nov 7, 2016 at 5:40
  • @AntoniusBloch Yes, a system reboot is required.
    – Arie Xiao
    Nov 13, 2016 at 5:31
2

DejaVu Sans Mono works for me. Of course there are other fonts out there that will work just as well.

enter image description here

EDIT: If you are running rtorrent in screen, make sure to set screen to use utf8 too.

2
  • I've updated my original post. Still looking for proper font to display as close as possible what I see in screenshot.
    – Pablo
    Feb 25, 2012 at 4:01
  • Links is broken
    – antogerva
    Mar 5, 2017 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.