I have installed Ubuntu 11.10 on a netbook (Intel 1.6 GHz and RAM 1 GB) with Windows XP. One week ago, Ubuntu stopped. That day had not installed any upgrade or any software.

When I try to start Ubuntu, I get is this message:

BusyBox v1.18.4 (Ubuntu 1:1.18.4-2ubuntu2) built-in shell (ash)
Enter 'help' for a list of built-in commands.


After a few seconds, I get the following error:

(Initramfs) udevd [94]: timeout '/ sbin / blkid-o udev-p / dev / sda'

udevd [94]: timeout: killing '/ sbin / blkid-o udev-p / dev / sda' [144]

The second of these lines begins to repeat a lot of times, until finally it appears this line:

udevd [94]: '/ sbin / blkid-o udev-p / dev / sda' [144] terminated by signal 9 (Killed)

Then the computer is locked and the only way I know to get out is by pressing CTRL+ALT+DEL to return to GRUB, boot Windows and close Windows.

For better understanding, I leave screenshots (click to enlarge):


This is my partition table disk:

  • /dev/sda1 → swap

  • /dev/sda2 → /, ext4

  • /dev/sda3 → /windows, ntfs

  • /dev/sda4 → /shared, fat32

I run "chkdsk" from Windows to check the Windows partitions (/dev/sda3 and /dev/sda4) and the result has been successful: no errors were found.

Then I tried booting Ubuntu in recovery mode and using previous versions of the kernel, but in all cases I have had the same error. Then I did a memory test (two passes) and no errors were found.

Finally I tried to start the netbook from a Live USB of Ubuntu 11.10 (created with UNetbootin), but I get the same error when I try to boot my Ubuntu installation from GRUB:

udevd [94]: timeout: killing '/ sbin / blkid-o udev-p / dev / sda' [144]

I think I have a hardware failure on the hard drive, but I don't understand why this affects only the Linux partition and not the Windows partition.

I don't know what else I can do.

1 Answer 1


It looks like the system could not find or mount the partition holding the root filesystem.

The BusyBox prompt is part of the initial RAM disk (initramfs), which is normally used in the early stages of booting Linux, before the root filesystem is loaded. This initramfs, along with the kernel and GRUB (bootloader) data, is typically stored in a separate boot partition. It appears your boot partition is intact.

blkid is responsible for scanning the hard drive and conveying partition information to udev so that it can mount the partitions. Apparently, blkid hung or took too long while scanning for the root partition, so the system killed blkid and the root filesystem could not be mounted. This can be caused by a faulty hard drive or damaged partition data.

There are several things you can do:

  • Make sure that the root partition is correctly specified on the bootloader.
  • Use badblocks to perform a surface scan on the hard drive, using a utility such as Parted Magic, and attempt to repair the root partition if it is damaged.
    • If the hard drive is OK, attempt to recover data from the partition, then delete the partition and reinstall Ubuntu, creating a new partition in its place.
    • If the hard drive has bad blocks, back up all data on the hard drive and replace the drive. The drive is likely to catastrophically fail in this case.

Edit: It appears the hard drive has failed. If the data is valuable, send it to a data recovery service. Replace the hard drive and restore data from backups, if available.

  • I don't know about not finding the root partition - the kernel always gave me Unable to mount rootfs when I mistyped the root= paramater into GRUB. I don't keep up with how Ubuntu does things, though.
    – new123456
    Feb 25, 2012 at 15:33
  • @DragonLord Thank you very much for your educational response :-) But how can I make sure the root partition is correctly specified on the bootloader?
    – peixe80
    Feb 25, 2012 at 15:34
  • I started the netbook with PartedMagic 2012.2.19 USB-Live, but does not load the hard drive. When I open GParted, after much time trying to access the disk, I received an error message telling me that it can't find the disk: subirimagenes.com/fotos-parted2-7477418.html What else I can do? Thank you very much!
    – peixe80
    Feb 25, 2012 at 23:22
  • @DragonLord I see that the hard drive has failed. I have already recovered data because I have access to the shared partition from Windows. Thank you very much for your help!
    – peixe80
    Feb 26, 2012 at 13:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .