This is a fairly new computer, only about a month old. i7 2700k, z68 motherboard, with a 1.5tb WD black HD, and a 128gb crucial M4 ssd.

I followed the instructions for setting up ssd caching, the SATA controller was set to RAID, I installed the intel software and enabled acceleration and it said everything went fine.

But when I went to reboot, I received the lovely "Reboot and Select proper Boot device" error message.

I checked the bios, and it was booting from the correct HD (I tried the only other option anyway just in case, it was the ~50 odd gb of unformatted space left on the SSD)

AFter that I entered the raid until (ctrl-i at boot) and removed the acceleration and deleted the raid array (because it was being used as a cache this was non destructive)

Still no boot. So I reinstalled win7 directly on the SSD, booted, and checked the HDD to make sure it hadn't been wiped. It hadn't, all the files were still there, including all the windows stuff.

I backed up my data to an external drive just in case, but I'd really like to get this install booting again.

I trawled the webs a bit, and have tried entering recovery mode and using the bootrec.exe and bootsect.exe to fix it, but to be honest I'm not sure what I'm doing with those.

My question is basically: How do I make my harddrive bootable again?

  • Kind of sounds like the boot device is somehow unavailable, what happens when you detach the SSD and boot without it? The commands you mentioned (fixboot and fixmbr, right?) should work, if not then there might be something else wrong... Maybe related to your RAID settings? Feb 25, 2012 at 22:20
  • 1
    I haven't tried detaching the SSD yet, but I have disabled it in the boot order. I will try that next. I've deleted all the raid arrays, but the SATA controller is still set to RAID. I tried AHCI briefly but that didn't help so I set it back to RAID. (Because I believe that's what it needs to be for SRT.) I'm running the built in repair utility and it's telling me the partition table doesn't have a valid system partition, but it doesn't seem to be able to fix it.
    – david
    Feb 25, 2012 at 22:24
  • Update: I used the diskpart program to set the partition as active. Now I'm getting a new set of errors.
    – david
    Feb 25, 2012 at 22:41
  • 2
    Success... It booted. After setting the partition to active it just took a couple of runs through the automatic repair. Now I'm back to square one though. I still want to set up the SSD caching.
    – david
    Feb 25, 2012 at 22:52
  • How about a link to those SSD caching instructions.
    – Moab
    Feb 25, 2012 at 23:26

2 Answers 2


I have successfully fixed the HDD so it is bootable, and subsequently reactivated SRT without the issue repeating itself. I will post some useful links incase anyone else stumbles upon this post with the same issue.

I'll leave the question unanswered, so if someone who actually knows what happens comes along they can get credit.

The only difference I can think of between it working and not, is how long I waited after activating acceleration before restarting the computer. The first time I restarted immediately, the second time the computer was on for about 4 hours before I restarted.


Here are the steps I took (as well as I can remember them) that seemed to make the disk bootable.

Before you do all this you might want to set your boot order to HDD -> CD so that every time you restart it first checks to see if the HDD is bootable, if not then it will take you back to the install CD and you can go into the recovery section and get your command prompt.

  1. Unplug the SSD. Probably not needed, but because I'd installed a second copy of win7 on the ssd to let me back up data I was worried the windows repair tool might target the wrong install.
  2. Go nuts with bootrec (I did all 4 possible options)
  3. Go nuts with bootsect (check the settings, I think I used something like bootsect /nt60 c: /mbr)
  4. Try to run windows autorepair about 4 times with no success. (To do this, chuck in the CD and boot from it, select your language, then down in the bottom left corner should be a repair option. It's the same as the way you get the console to do bootrec/bootsec)
  5. Set the partition to active as detailed in the last link. (Copied here incase the forum dies, commands separated by semicolons: Diskpart; list disk; select disk 0; list partition; select partition 1; active; exit; exit (Make sure you replace 0 and 1 with the disk/partition your windows install is on)
  6. Try automatic repair again. I think it had a cry the first time and wanted to contact microsoft. Just reboot and do it again. I think I ran it maybe 3 times before the harddrive would boot.

Hopefully this helps someone. If you're reading this and you understand what the actual issue is I'd love it if you could post an answer explaining why activating SRT would cause the accelerated HDD to forget how to boot.


This happened to a friend of mine at a LAN. All other settings were OK, but for some reason the BIOS had set the HDD mode back to IDE. I changed it back to RAID and it now works fine.

  • Sorry for the horrendous typos. I'm using my galaxy tab 7.7 Sep 2, 2012 at 20:06
  • Can you fix them? The typos have seriously disrupted the meaning of your answer.
    – evan.bovie
    Sep 3, 2012 at 1:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.