I'm using VirtualBox on my Windows 7 (64-bit) laptop, in order to manage 3 Ubuntu 10.04 VMs for web development. One is 32-bit, the two others are 64-bit.

For the past two days, when I try to reach my guest-hosted website from the host OS, I'm experiencing slow network speeds. When I look at my Firebug > Network tab I see that the main files require between and 5 and 10 sec to load. I got this message after logging in:

system information disabled due to load higher than 1.0.

I see this message more as a symptom rather than my real problem.

The network problem has reached all three Ubuntu guest OSs.

Here's my config:


  • Config:
    • Windows 7
    • 8GB RAM
    • SSD harddrive (6 months)
    • VirtualBox 4.0.10
      • Host-only adapters configured in virtualbox > file > preferences > network :
        • ip:
        • netmask:
        • DHCP active:
          • Server address:
          • Server Mask:
          • Lower address bound:
          • Upper address bound:
  • Network :
    • My wired connection is configured with the virtualbox bridged networking driver active in my card advanced properties
    • IP:
    • Gateway:
    • DNS from Free (French ISP) :
      • IP:
      • IP:

My windows hosts config file contains redirections to the bridged card like this:

192.168.0.XXX (vm ip)       vmName www.domaine-on-this-vm.com

When I reach my guest hosted website from the host and I look at my Firebug > Network tab, I see that the guest takes between 0 and 10 s to respond.

GUEST (1 @ 32-bit and 2 @ 64-bit, so I don't think number of bits matters)

  • 1 processor
  • 512 ram
  • acceleration:
    • vt-x/amd-v = ok
    • nested paging = ok
    • pae/nx = ok
  • Network :
    • adapter 1 = bridged network (intel pro/1000 mt desktop)
      • IP: 192.168.0.xxx (vm ip staticaly fixed in /etc/network/interfaces (see below)
    • adapter 1 = bridged network (intel pro/1000 mt desktop)
      • IP: 192.168.20.xxx (vm ip fixed via dhcp in /etc/network/interfaces (see below)
    • File /etc/network/interfaces
      • # This file describes the network interfaces available on your system
        # and how to activate them. For more information, see interfaces(5).
        # The loopback network interface
        auto lo
        iface lo inet loopback
        # The primary network interface
        auto eth0
        iface eth0 inet static
        auto eth1
        iface eth1 inet dhcp
    • File /etc/hosts:
      • vmName www.domaine-on-this-vm.com
  • Software installed:
    • apache2
    • php5
    • samba
    • openssh
    • compass (on ruby, css framework development)
    • svn

Everything was doing fine during 5 months with those configs/software before the bug begun.

Facing this, I've tried to:

  • raise the amount of RAM and the number of processors
  • re-install a fresher version of virtualbox and an older one
  • create a new VM with the same .vdi
  • change the adapter type from Intel pro/1000 desktop to anothers
  • tried different network interfaces config file alternatives (no dhcp / dhcp)
  • tried to nslookup my ISP provider's DNS automaticaly filled in the /etc/resolv.conf file (and it's OK)

...but with no effects.

One more symptom is that during my debug process, I've rebooted my VMs a lot, and I got a disk issue message durinng boot: "your disk haven't been checked for last 24 boots, check forced" or something like that, then it tells me a short message that I can't read, and only then I got the login field.

I'm really new to all Linux things (and not english fluent...). I can't see if it's a network issue or a disk issue, please let me know which commands might help me to dig into this?


I've found out my problem: My laptop battery management plan.

Since I've had to work on a train last week end, I've tried some network configurations to be able to access my VM without network (no host-only at this moment) and this is why I was looking in that direction.

In the end, it was just because I've turned on the "economic mode" on my laptop battery.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.