For all of my Excel spreadsheets when I attempt to open them (by double-clicking in explorer) I get the message "Windows cannot find C:...". The files are there, and are valid zip files as seen by 7-Zip. There are no apparent lock files in the directories.

I did just install Norton-360 over the weekend (replacing Kasperski), but the Norton log shows no events related to Excel. However, while installing Norton I did reboot with some Excel files open.

Presumably something is hosed in my Excel configuration but I don't know what.

Update (Before actually posting) -- I found an article that suggested turning off Advanced Option "Ignore other applications that use DDE", then doing excel.exe /unregister followed by excel.exe /register. I tried this but I suspect that the two Excel calls were ignored (Excel opened, but no obvious change). With that option off the spreadsheets load OK, but not with it on. And, curiously, spreadsheets load OK with the option on or off if I open Excel first and then open the spreadsheet in it.

Does anyone have any idea what effect leaving that option off will have?

Update 2 -- I tried running the "repair" option. It said it corrected a couple of config things (without saying what they were), but I still get a failure if I double-click an Excel file with the "Ignore other applications..." option checked.

Update 3 -- I managed to fix this problem, but failed at the time to come back and say what I did, and now I can't remember for sure. But I think it had something to do with "Options"/"Save" and some of the values there. Something to do with AutoRecover, perhaps. (Possibly there was a file in recovery and I had to specify "Disable AutoRecover for this workbook" to let bring-up get past it. Or perhaps the AutoRecover file location was hosed.)

Anyway, if it happens to someone else, and you find the fix, post it below and I'll mark it answered.

DDE is used so that one program can communicate with or control another program. This forum has some answers that may tell you the exact culprit, but your situation is slightly different. Something somewhere in your registry seems to be conflicting.

Other troubleshooting tips & registering the entire registry for excel

Using this link as a reference

If you get the problem to come back you can try starting excel in safemode (actual location may vary)

"C:\Program Files\Microsoft Office 2003\Office11\Excel.exe" /safe

From the link:

If Excel does start in Safe Mode, the cause of the problem is likely to be a corrupt or otherwise misbehaving add-in or other start up file. To test this, move all your add-ins to another folder. Then, from the Tools menu, choose Options, and clear the setting for Alternate Startup Location on the General tab. In later versions of Excel, this setting is labelled At startup, open all files in:. Under normal operation, Excel will automatically open all the files that are contained in the folder specified in this option. If this setting is cleared, those files will not be opened. After clearing that setting, close Excel and restart it normally. If Excel starts, then the problem lies in one of the files in the alternate startup folder.

You can have excel register all registry entries with these commands. This will set excel back to default settings. You may also have to use the full path of Excel and not jsut Excel.exe

Excel.exe /UnregServer
Excel.exe /regServer

And as always when messing with the registry back it up first .

  • Options says I don't have any active add-ins. "At startup, open files in:" is blank. This is an unmodified, uncustomized Excel 2007 install. I don't do anything remotely "fancy" with it. – Daniel R Hicks Feb 28 '12 at 2:26
  • And the /UnregServer and /RegServer options are ignored -- Excel just opens as normal. – Daniel R Hicks Feb 28 '12 at 2:37
  • @DanielRHicks: Did you run the unreg/reg commands as an administrator? Since installing the application requires administrative capability, fixing it probably does too. – K.A Dec 31 '13 at 8:41

Unchecking DDE in options and running excel.exe /unregserver and excel.exe /regserver didn't work for me but this fixed it:

  1. Shift + Right click any .xls file to open context menu

  2. Click "Open with"

  3. "Choose default program" to browse for excel.exe (usually installed in C:\Program Files\Microsoft Office 2003\Office11\Excel.exe)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.