8

How to access the mapped network drives from the mingw shell? When I try

cd y: or cd /y or y:

All I get is No such file or directory or sh.exe y:: command not found.

I am able to access the same mapped Y: drive using cmd. I would like to know how to do the same using mingw shell.

8

Try cd /y/ to solve your problem

  • 3
    Care to explain why it works this way? – Ivo Flipse Mar 26 '12 at 13:22
  • I'm able to access the drive from mingw shell if the drive is actually connected. That is, if I double click and open the drive in Windows Explorer and then use Mingw to cd into it, then it works. – yasouser Mar 26 '12 at 15:00
3

I find I have to use the mount command first. If I have a USB stick on drive E: then in the mingw shell:

mount e: /e

Only then can I run cd /e/. You can run mount without parameters to list all the currently known file systems. umount /e will remove the link between E: and /e/.

  • I have a "mapped network drive" as "S:" but when I run $ mount S: /s in MingW64 (git back) I get mount: warning - /s does not exist. – iX3 Nov 6 '17 at 0:55
  • It seems that my problem was that I was running git bash in elevated mode (set "Run as administrator"), and evidently the admin user didn't have an authenticated session with the file server or something like that. – iX3 Nov 6 '17 at 1:03
0

Try this format in MINGW64 shell (Bash for windows)

$ cd //IP_Address_of_remote_drive/Path/To/The/Folder/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.