I'm having trouble getting my Comodo signed SSL Certificate to work with Internet Explorer in Apache2.

Internet Explorer gives an error that there is a problem with the certificate.

I tried all different combinations of SSLCipherSuite and SSLProtocol. I completely disabled SSL 3.0. Nothing helped.

Here are some options I tried: (not all at the same time)

SSLEngine On
SSLCipherSuite HIGH:MEDIUM
SSLProtocol all
SSLProtocol -all +SSLv2
SSLCipherSuite SSLv2:+HIGH:+MEDIUM:+LOW:+EXP
SSLCipherSuite ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL

My client complains because of SSL errors.

There is an Error with the SSL Certificate

I don't know the exact version of Internet Explorer they're using but I can reproduce the error with Internet Explorer 9.0 (activated SSL 2.0).

  • I found this in /etc/apache2/mods-enabled/ssl.conf: SSLCipherSuite HIGH:MEDIUM:!ADH After commenting it out IE only shows warnings and loads nothing external: js, pics, css Not perfect but better than a blank warning page. Also the address field is red (unsecure certificat). – Olli Feb 28 '12 at 16:53

Have you considered that the certificate may either be revoked or just plain invalid?

In Internet Explorer, click the padlock button in the address bar when visiting the webpage. click "View Certificates" on the popup box. This will show you the Windows (not Internet Explorer) view of the certificate.

Internet Explorer may not trust your certificate for a variety of reasons: * The certificate may be invalid * The certificate may be trusted by a CA that your computer doesn't trust * The certificate may have been specifically revoked by the CA * The CA may have been specifically revoked by your machine (Comodo has been compromised in the past)

  • FF and Chrome say it's valid – Olli Feb 29 '12 at 9:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.