Here is the story. I wasn't aware that "OS X Server" was an actual operating system to install, I thought (seriously!) it's just another application or bunch of apps working nicely together under the OS X Snow Leopard. Because I was struggling with my imap, pop and smtp servers to install locally for last 24 hrs, my mate dropped me the "OS X Server" dmg over the LAN to try it out if this is what I need. So I've installed the package from dmg file then opened the Server Admin app. Nothing was detected, no servers, so I've run this command (don't remember exactly):

sudo launchctl load -w /(...).plist

The local server seem to appear on the list and I begin to investigate further.. (I already had running Apache, mysql, postfix) and I expected this to appear on the list etc.

.. when prompted for serial number I skipped this step (to see more options) by clicking "Save" button and then my machine restarted without any prompt. The OS X Server process began. I realised quickly it's not the action I want to take. Now here is the trick...

How do I roll back to my normal Snow Leopard? I know it's there (I've checked from terminal from my original installation disc) and seems like all data are there. I have time-machine backup but probably 3 weeks old and some significant changes were made since then I don't want to loose. Whenever I boot my macbook, it starts the Server installation process, but I haven't done anything yet. Is there a special boot record or something like this where I can force it to start from my previous location? How do I get rid of this? I simply don't want to install new os and cancel the current process but this thing sits on my drive, it's a CD I could simply eject, right?

migrated from stackoverflow.com Feb 28 '12 at 22:19

This question came from our site for professional and enthusiast programmers.

  • Do you still have the snow leopard install disk that came with your machine? – Simon Sheehan Feb 28 '12 at 2:05
  • yes, I am booting from it now, I can access everything through terminal. I've tried "bless" but this didn't work. – lokers Feb 28 '12 at 2:09
  • 1
    Backup your data and just do a clean reinstall. – Simon Sheehan Feb 28 '12 at 2:10
  • well, this is what I am trying to avoid... Believe me it will be quite a challenge to get all this stuff configured again : ( I am rather looking into solution that will "re-route" the booting location and let me in to the old system. – lokers Feb 28 '12 at 2:14
  • 1
    @lokers, it's likely that you inadvertently installed SLS over your existing SL OSX. It may take you less time to just install fresh :-/, and that option is almost guaranteed to work right – Joshua Feb 28 '12 at 2:17

It seems you have already installed the server - it may be easier simply to back up your data and do a clean install of Snow Leopard.

  • 1
    It definitely sounds like a simplest route but believe me I will have to spend whole week rebuilding everything to the state it was before and downloading/installing/configuring all that stuff. I am backing up my data now, but I am still aiming for a fix, at least I want to boot it properly and see if any changes were made or maybe everything will be fine at the end? Do you guys have any experience with bless or rEFIt ? I think I will give it a go and read more... – lokers Feb 28 '12 at 3:05
  • @lokers given the nature of the "server" - it's a bunch of extra services - is it possible that this could save you some time? news.softpedia.com/news/… – Joshua Feb 28 '12 at 4:07
  • that's very good point, although I've tried to install version for Snow Leopard... – lokers Feb 28 '12 at 14:21

This question is probably more fitting for SuperUser.com or perhaps ServerFault.com but here goes...

You MAY be able to get things back to order by "repairing" the disk. I would find another bootable disk, boot on that, mount the original read/write - like this:

mount -o remount -w <drive>

Then fix what's wrong - that is, edit however it is that OSX records that it was about to do an installation.

There's also some chance that the installer will discover that your disk already has an OS on it and give you an option to abort gracefully first! Only someone who really knows OSX will be able to help you - hence my suggestion you look at the links I cited above.

  • I am booting from original Snow Leopard CD. Thing is I don't know what to fix and where exactly.. I am not an expert in this subject. I have terminal access so I've tried "bless" command (/usr/sbin/bless --folder /Volumes/Macintosh \HD/System/Library/CoreServices --verbose ) but this didn't work well, probably because they both sit on the same drive/partition.Thanks for the links, I'll check them out right away, I am "googling" for last few hours, there must be a simple way to recover all I am sure about it : ) – lokers Feb 28 '12 at 1:30
  • wait a second? will it really re-install my os x? link ... maybe I am tired, but on this page requirement is to have an OS already in place... ;/ – lokers Feb 28 '12 at 1:40
  • @lookers ...The advice I've given here is correct. If you are brave, continue forward and it MAY give you a chance to abort. Frankly, while I know a lot about Linux / Unix, having first used Unix (upon which Linux is based) in about 1985, I don't know much about OSX itself. That's why I suggest you need to engage someone who is truly experienced with OS installations on the Macintosh. HOWEVER, all of the Unix-based operating systems I've dealt with in the last 15 years or so have provided intelligence on this point - that is, they ALL ask you: this will wipe out your disk, are you SURE?! – Richard T Feb 28 '12 at 3:09
  • @lookers ...You ARE aware that SuperUser.com and ServerFault.com are affiliated with (offshoots from) StackOverflow.com, aren't you? If not, go log in and find out about them! ...Somewhere in your profile section, they make creating accounts on these sites easy... Check out my profile for an example, if needed... Good luck, RT – Richard T Feb 28 '12 at 3:11
  • @lokers - ...Just realized I was misspelling your name (handle)! My appologies! And, good luck - somehow I think you need it! -smile- – Richard T Feb 28 '12 at 3:34

I thought (seriously!) it's just another application or bunch of apps working nicely together under the OS X Snow Leopard

Well, it quite honestly is. You can still use your system as normal, it just has extra services.

From what your saying, you basically overwrote your installation of snow leopard. The only real fix that will do anything is to do a fresh install using your original install disk.

Another option is to find which extra services are running (apache, mail, whatever), and just disable them.

  • 1
    That's what I was expecting, I thought it will just add some services and give me GUI for all of that. To be honest I just needed smtp and iCal server locally for some dev work. Anyway, worse case scenario I can always revert to my backup from last month (time machine) and most of htdocs sits on repo... Still, I am going to try few things and rescue the current system, I will need luck though... – lokers Feb 28 '12 at 3:15

I was trying to cancel this installation for few hours, I've done backup of my data and I was prepared for the worse. Finally, I clicked "proceed" as I had nothing to loose. Surprisingly, the server installed properly (it looks fine so far), I am still able to use my OS like before (so it was additional layer! not the whole os), some additional apps for server management were added and new admin user created. I see few errors and warnings in system log and few other places but they may be still related to the dovecot installation which I was doing couple of days ago.

Anyway, at this stage, I can tell the installation didn't break anything, although I might be wrong and in few hours time system will get hiccup. If this will happen, I will post an update here.

  • UPDATE: apart of some permissions issues the system seems to be stable, looks like it is possible to install the server over existing system and even on macbook pro after all. – lokers Feb 28 '12 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.