I am trying to run tor on my slackware machine and when I do I get the error:

tor: /lib64/libc.so.6: version 'GLIBC_2.14' not found (required for tor)

So I run the command:

slackpkg upgrade glibc

Which tells me that there are no packages that match the pattern for upgrade.

So then I run the following command to reinstall glibc:

slackpkg reinstall glibc

And when I am prompted by the reinstall screen to choose the packages that I want to reinstall, I notice that glibc-2.13_64-5_slack13.37.txz is the latest version of glibc.

Is it possible to either run tor without the latest glibc, get glibc_2.14 for slackware 13.37 another way, or some other solution to properly run tor on slackware 13.37?


You need to uncomment a mirror URL that ends in 'slackware64-current', e.g.


If you use a mirror that ends in 'slackware64-13.37' you won't see GLIBC 2.14.


You are using Slackware64? If glibc-2.13_64-5_slack13.37.txz is the package name, then you are installing the wrong package; search the 64-bits version and try again.

  • 1
    I am not searching for the package, I am getting it directly from the mirror that you uncomment, inorder to use the slackpkg command. Also I am having a hard time finding the version 2.14 glibc for slackware on the internet. Is there another distro that is close enough to slackware, where I can you that package? – NSNolan Feb 29 '12 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.