I have disabled the service for the player but why is it enabled in the first place and how do I get rid of it? (Do not want to play media sharing at work)

From How To Disable Windows Media Player 12 Sharing :

  1. Go to Network and Sharing Center (found by clicking your wireless/Ethernet icon in your taskbar)
  2. Select Homegroup and Sharing Options
  3. Select Choose Media Streaming Options
  4. Click Block All
  • WMP12 doesn't have the "simple-minded solution" – Mark Sowul Jan 25 '13 at 17:08

It's also possible to disable the media sharing from Services

  1. Click "Start" and select the "Control Panel."
  2. Go to "Administrative Tools" and open "Services."
  3. Find "Windows Media Player Network Sharing Service" and double-click on it.
  4. Click "Stop" under the "General" tab and then select "Ok."

http://www.ehow.com/how_7209048_disable-windows-media-player-sharing.html

  • It still works years later. For anyone else with this problem consider changing the start-up type to disabled it's on the same tab mention in step 4. – James Draper Jan 24 at 17:59

1.Open Notepad and Paste:

@echo off

sc config "WMPNetworkSvc" start= disabled

sc stop "WMPNetworkSvc"

pause

2.Save File (Example): _WMP_Sharing_Disable.bat

3.Right-Button => Run as Administrator

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.