1

So this peculiar problem has started on my Mac running OS X 10.6.8.

Every time I open Opera/Safari/Google Chrome to surf the web, certain web pages do not open.

Google.com opens after a 20-25 second wait (which is not normal).

If I search for another website like macrumors.com, the page will take a long time to open and then say "Network problem: Check that the address is spelled correctly, or try searching for the site." This problem occurs on both my Mac as well as my iPad. If I go back and refresh the page, the same message will be displayed on screen instantly (it won't attempt to reload the page).

I tried pinging www.google.com and 192.168.1.1 for which my results were:

PING www.l.google.com (209.85.148.147): 56 data bytes
64 bytes from 209.85.148.147: icmp_seq=0 ttl=46 time=403.227 ms
64 bytes from 209.85.148.147: icmp_seq=1 ttl=46 time=400.221 ms
64 bytes from 209.85.148.147: icmp_seq=2 ttl=46 time=402.390 ms

and

PING 192.168.1.1 (192.168.1.1): 56 data bytes
64 bytes from 192.168.1.1: icmp_seq=0 ttl=64 time=0.945 ms
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.864 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=0.834 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=0.874 ms

Also, I use a DLink wireless modem router (DSL 2750U)

Any ideas what the problem may be?

PS: I do not know how to use terminal properly, so please dumb down the suggestions for me as much as possible :)

0

It might be DNS issues..

First, I would try resetting your router and see if that helps.

Second, I would try flushing your local DNS cache-- I only know how to do this from the terminal though:

  1. Open Terminal.app (Finder->Applications->Utilities->Terminal)
  2. Type the following and press enter (enter your password if prompted): sudo dscacheutil -flushcache

You can also try using Google DNS instead of your ISP's DNS server:

  1. Open System Preferences and Then Click the Network icon.
  2. Select your active network connection on the left, and then click Advanced
  3. Click on the DNS tab
  4. In the DNS Servers section, click the [+] button on the lower left
  5. Type 8.8.8.8 and press enter
  6. Click the [+] again, and type 4.4.4.4 and press enter
  7. Click OK and then Apply

Your computer will now use Google's free DNS servers instead of your router/ISP's servers. Test it out, if you still have problems, simply follow the steps above but delete the 8.8.8.8 and 4.4.4.4 entries (highlight each entry and click the [-] button on the lower left). Your computer will return to using the default DNS server.

  • Thanks for the quick response! I used Google DNS instead of my ISP's DNS server. Worked like a charm! Thanks so much! Appreciate it! – Prat1292 Feb 29 '12 at 17:52
  • @Prat1292 Also, these may or may not be the fastest DNS servers for you. Check out code.google.com/p/namebench. It takes a while to run, but it will give you a nice list of fast DNS servers for your location. – InChargeOfIT Feb 29 '12 at 18:14
  • Will do, thanks so much for the additional info! – Prat1292 Feb 29 '12 at 18:46
0

mDNSResponder could have become wedged. Try killing it (your system will automatically re-launch it).

sudo killall mDNSResponder

For more information see this Answer:
MacBook can't use internet, but nslookup and ping both work

0

Same problem just occurred on wife's iMac running 10.6.8

Initial symptom was failure to connect to imap.gmail.com in Mail, but while debugging I noticed certain major websites also didn't load in Safari (eg, Apple.com) but most curiously did load in Firefox.

The solution was to switch the IPv6 setting from "automatic" to "off" in Network system prefs, TCI/IP panel.

This answer is specific to Mac OSX 10.6.8

1) Open Apple Menu > System Preferences…

2) Click on the padlock at window bottom left and enter an admin password

3) Select the Network panel in the Internet and Wireless section

4) On the left hand list of ports, select the one you are using to connect to the internet

5) Click on the Advanced… button, lower right

network panel

6) If it isn't already selected, click on the TCP/IP tab

7) Click on the Configure IPv6 popup menu button, change it from "Automatically" to "Off"

Advanced panel after

8) Click on OK - you will return to the prior panel

Click on "Apply" and you are done

  • Can you explain further how you disabled IPv6 on your iMac? Please see How to Answer or take our tour for more information. – Burgi Aug 2 '16 at 7:51
-2

I was using DHCP, I did have a valid IP,SUB,GATEWAY, however all I needed to do was renew the DHCP lease and it started working

  • 2
    Can you explain how you renewed the DHCP lease? As it stands, this answer is not fully usable. – bwDraco Oct 22 '12 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.