I am trying to delete the folder in C:\Program Files\McAfee\VirusScan\Current as a member of the computer’s Administrators group. This is a standalone computer, so no domain or anything.

The original owners of the directory were:

  • Creator Owner (Special)
  • System (Full)
  • Administrators (Group) (Full)
  • Users (Read-only)
  • Trusted Installer (List & Special)

MyUser is a member of the Administrators group, so I’ve tried to delete the directory, to which I receive a message saying that I need permissions to do so from the folders’ owner.

Fine, I changed ownership to MyUser, trieid to delete the folder. Same results, now the message reads “You need permission from THISCOMPUTER\MyUser to make changes to this folder” (that’s my logged-in user!)

I went to the security tab, removed permissions inheritance; now only MyUser has permissions on the folder, nothing is being inherited, MyUser is the owner of the folder, and I have propagated the changes down the hirerarchy. All the permissions, basic and advanced, are set for this user (as in http://technet.microsoft.com/en-us/library/cc772196.aspx)

Just for good measure, I’ve also checked the Effective Permissions, which confirm that MyUser (which, yes, is the user I’m logged in as) can do anything with the folder and its contents.

Well, not really. It still can’t. I even tried restarting the system to make sure there was no open anything, even tried Unlocker, but stop short of asking it to remove the files at boot, as that is not a practical solution.

Any ideas? I have several year’s experience with Windows both on the desktop and in server environments, but there are some options in Windows 7 that are breaking apart from all I knew about how Windows manages file system security.

  • You might want to try in Safe Mode, or check McAfee's settings. I use Norton, which has a "tamper protection" option enabled by default, that prevents modification of any Norton files. It goes as far as making System Restore fail. McAfee might have a similar option/protection. – Bob Mar 2 '12 at 8:51

You might consider trying to run the command prompt as Administrator (Right click on a shortcut for command prompt, and choose that option) and delete the folder from the command line.

Switch to the parent directory, and do a del /S /Q "FolderName"

  • 1
    Hi, thanks for your reply. I have tried that, and I get "Access Denied" for each file – user120845 Mar 1 '12 at 16:16
  • Same when I tried running explorer as an Administrator. It keeps telling me that I need to get permissions from the owner, and it does not matter that the owner is the logged-in user, or a group to which the logged-in user (or the user running explorer) belongs to BTW, UAC is off. – user120845 Mar 1 '12 at 16:23
  • You could also try to delete the folder in Safe Mode and see if it allows you. Also, as a last resort, you could boot from the Windows CD and enter repair mode or boot from a Linux Live CD and try there. – dotnetengineer Mar 1 '12 at 17:12

Have you disabled all relevant McAfee programs first? Many antimalware programs will install a "self-protection module", which is a kernal-level file system filter driver which starts at boot and intercepts any attempt to modify the programs files. I suspect this because I've never seen any Windows permission dialog saying you need to get permission from an owner.


You could try taking Ownership of the folder and then delete it. Be sure to click on the Replace owner on subcontainers and objects

  • 1
    Of course I've tried that. When MyUser is the owner, and while logged with MyUser, it tells me that MyUser should provide permissions... – user120845 Mar 1 '12 at 17:08

First assign your user full permissions to the folder/directory in question. Now delete the folder/directory. If you are still receiving Access Denied errors then try the following:

  1. Open a command prompt using Run As Administrator
  2. Type: net user administrator
  3. Type: net user administrator /active:yes
  4. login using the administrator account
  5. on the target folder/directory right click properties
  6. security tab => edit => Add => Administrator
  7. select all options in the Allow column
  8. click ok
  9. delete the target folder/directory


  • This method will work in Windows 7.
  • When finished, don't forget to disable the Administrator account!


Enable / Disable the Local (Hidden, Built-In) Administrator Account

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.