I have a Snow Leopard + CentOS dual boot system setup. When I log in to Snow Leopard, it tells me that it is unable to mount the disk that i have just inserted. It is referring to my centos partitions. It gives me the option to initialize or ignore. I would rather that never come up incase I accidentally erase my linux partitions.

I tried to follow the instructions on http://hints.macworld.com/article.php?story=20060930150059172

It advices to create /etc/fstab and add noauto at the end

UUID=F0E430C1-5558-3BB3-9FA9-6904B663FEEA none hfs rw,noauto

However, I can't find the UUID or the volume label on the linux drives/partitions. I tried diskutil info /dev/disk1 diskutil info /dev/disk1s1

I looked in system.log; There is no UUID it seems. Where can I find it? And if I can't, can I use /dev/disk1s1 in /etc/fstab?


Are you using rEFIt? I wouldn't dual boot a Mac without it:

Screenshot from rEFIt boot menu

It has an option to synchronize the MBR and GPT partition tables - it's just conjecture, but this might solve your problem.

On a secondary note, it's very unobtrusive and comes with a complete uninstall guide - so an attempt shouldn't hurt your system.


  • Thanks for the response! I do have refit installed and I synchronized them. The linux partitions are in lvm. I'll try to convert to non-lvm and then try to sync the partitions again to test. – garg Mar 10 '12 at 23:59

According to the thread Ext4 partition: Getting rid of Initialize, Ignore or Eject, this may be happening because the CentOS partition is formatted as ext4.

Reformatting it as ext3 should solve the problem.


synchronizing mbr and gpt did not work, and reformatting didn't work.

I ended up using OSXFuse http://osxfuse.github.com/ and was then able to tell it to not automount.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.