5

I have a WD Essentials MyBook, which was working fine as my Time Machine volume on Snow Leopard. I have since upgraded to Lion and now the disk is really slow to access.

I tried to take the disk out of the caddy and just plug it into SATA and it comes up saying that the disk "could not be initialised".

Having done some research it appears that the MyBook SATA <> USB bridge does hardware encryption on the fly regardless of you enableing encryption or setting a password in the WD Tools.

Does anyone know of a way I can extract the data from this disk without going through the decryption bridge? I have done a disk check on the disk and it comes back fine, leading me to think the issue is with the caddy.

3
  • Investigate why it 'could not be initialised' - i'm inclined to say "use Windows" but that's only because i know when disks 'cannot be initialised' that you can easily find more information/convert to basic/mark as active... It all depends on your experience and what software 'tools' you have available!
    – HaydnWVN
    Mar 9 '12 at 11:52
  • Well done! Totally upto you how you close out your question, i'm tempted to advise you to post your comments as an answer, wait the couple of days and mark it as your solution! :)
    – HaydnWVN
    Mar 12 '12 at 9:35
  • 1
    Cheers, comments have been upgraded to an answer.
    – JTotham
    Mar 12 '12 at 10:01
1

I found and worked round the 'problem' in the end, its was 16 bad sectors that where locking up the disk in OSX over USB.

Fix Part1:

The disk HAS to be read via the MyBook caddy as even if you dont set a password in the software the caddy STILL does full HW disk encryption for you making it unreadable by any other method.

Part2:

In the end i connected the disk via the caddy to my linux NAS then using dd_rescue with various flags i managed to copy all the data out of the disk into a 700gb iso (Handily i had plenty of space free on my NAS).

1st time i ran it, i got lots of bad sector errors on the console and it gave up.

Part3:

To get round the issue of the bad sectors i used dd_resuce and started from 0 working forwards with large reads till i got errors (3.5gb into the copy), then ^c to break out and skipped a bit and started from 4gb going forwards. I left that running overnight and then in the morning i started the 3rd part running from 4gb running backwards (backwards is slower then forwards), reading individual 512k sectors so as to recover the maximum amount of data.

All 3 runs where set to output to the same file, DDRESCUE when started creates a full size but blank file and never closes that file so you can just keep grabbing little bits and filling it up. This was all writen into the same ISO untill it was basically a full backup -8kb (16x512b sectors).

Part4: Having done this i just plugged the drive into OSX and it was detected as a local Time Machine volume and away it went restoring all my data.

1
  • I tried plenty of methods of presenting the ISO directly over the network from the NAS, all failed to be detected correctly in Time Machine. This is due to a change in the way TM now works with network volumes, instead of just creating a folder and filling it full of data like it does on a local disk. It creates a stripped virtual volume inside a file on the network drive and writes to that instead.
    – JTotham
    Mar 12 '12 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.