31

When cutting/copying some cells to paste them into another sheet/page, sometimes Excel freezes/locks up and fades out. At the top toolbar it says in brackets "not responding".

Eventually, I must click 'X' to close the program. It offers to wait for the program to respond, but never does – it just does nothing until I finally close it, where it offers to recover files etc.

Is there an issue with memory here? What can I do to stop it locking up?

4
  • How much data are you working with when this happens? Does it happen when you copy a small amount or a large amount or both? What sort of data are you copying? Only values or also formulas? Have you tried copying something that froze before piece-meal to see if it freezes in smaller chunks? How often does this happen? – Raystafarian Mar 5 '12 at 12:08
  • @barry which windows system is it? – Psycogeek Mar 5 '12 at 12:43
  • lot to say.. im running windows 7.... it happens generally with larger rather than smaller volumes.... sometimes with formulas sometimes without....and it happens a lot?? – Barry Mar 5 '12 at 15:54
  • 1
    Old question, but I've found this problem disappears with the following solution: upload the spreadsheet to Google Drive, open in Google Sheets. Now you no longer have an Excel problem. – Lou Aug 23 '19 at 12:44

25 Answers 25

26

I have had a similar problem on a new, plenty-fast i7 machine. Even with a trivial spreadsheet with half a dozen cells and one formula, Ctrl-C would freeze Excel for 20-30 seconds. I, however, would always get control back after that time. Turned out to be something to do with default printer. My default was a network printer that was offline. When I went to control panel and changed my default printer to CutePDF writer or something like that, copies became instantaneous as they should be.

2
  • Seems this worked for me also. Win10 x64. Thanks! – TravisWhidden Feb 3 '17 at 21:59
  • 3
    wtf bbq? Excel crashing for me all the time. Set default printer to local pdf generator and poof problem solved. – Will Shaver Mar 13 '19 at 17:35
12

Go to File \ Options. Select the "Advanced" tab. Go to the "Cut, copy, and paste" section. Uncheck "Show Paste Options button when content is pasted" and "Show Insert Options buttons"

3
  • Not sure why you had a -1 score, have an upvote. This fixed the issue I was having! To add to this, when Excel was freezing I ran process explorer and targeted the frozen window, it said that the window was dwm.exe instead of excel. Might have something to do with excel trying to display the paste options and dwm.exe. Might have been dwm.exe because the window was 'not responding', not sure. – qroberts May 8 '16 at 14:25
  • Unfortunately that didn't work for me. – GoTTimw Sep 8 '16 at 16:44
  • 1
    Old question, but this worked for my Office 365 on win10 x64. – corsiKa Feb 7 '17 at 1:30
7

I had this problem on a worksheet with no macros - it turned out to be conditional formatting. When I removed the conditional formatting from the whole worksheet all was working again. Then I added it back.

1
  • 2
    Incredible, I had the same problem and tried all the weird suggestions but could not image that Conditional Formatting was beyond all control and any paste would imply pasting a lot of new formatting and creating new rules. I removed them all, tens or maybe more than a hundred and now paste is normal (fast) again. Thanks for the tip! – Vasile Tomoiaga Oct 23 '18 at 13:39
4

I do not recall this exact problem but I have had similar problems on a number of occasions. Like you I had to abort Excel to clear the problem and it told several such failures before I identified the cause.

The cause was Excel waiting on a question about the operation I had requested which was hidden behind the main Window. I have since discovered that getting that hidden question to display can be difficult but is possible. I do not know why, on rare occasions, the question is not on top as it usually is.

Try looking for a hidden question next time this happens.

3
  • 2
    Thanks.. but where to look for 'hidden question'?? – Barry Mar 5 '12 at 11:54
  • 1
    I have not had this problem for a while and do not remember the details. You could try minaturising Excel but I doubt that would work because of the outstanding question. My recollection is that I would click "Show Desktop" which minaturised everything even if there was an outstanding question. Then, when I maximize Excel, the question would be displayed on top. Sorry, this is not more helpful but the true answer is that I clicked things until something happened. – Tony Dallimore Mar 5 '12 at 12:16
  • are there any macros in the sheet? Calculation is manual or automatic? – datatoo Mar 8 '12 at 23:50
3

In my situation I had an excel sheet with Conditional Formatting on some cells and for some reason this Conditional formatting was copied a couple of hundred times, probably when I copied the cell the custom formatting for the entire range of cells was copied as well.

I had to remove the Custom Formatting on hundreds of cells which took ages as you can't select multiple Rules when deleting them. So manually deleting one rule after the other, while every Delete takes a couple of seconds...well you get the point.

Anyway, my Excel sheet is quick again when the Conditional Formatting was reset to only a few Rules.

3

In MS Office 2013, Go to File, then Info and Select "Check for Issues" (Inspect Work Book) , then Select Inspect Document.

There will then be a Checklist for what you want to check, I just left the default checks.

Then Hit Inspect, it'll then tell with Explanation marks "!" what some of the issue are. Hit remove All in each category and then try to copy and past again.

Worked for me, best of luck!!

1
  • I'd never have guessed something like that would work! – Arjan Dec 30 '16 at 16:15
3

For me it was a TeamViewer. Check for every program that could use clipboard.

1
  • Awesome, thanks! This solved it, no wonder why it started to freeze suddenly. I had opened TeamViewer connection. – Quirzo Aug 16 '19 at 10:59
2

Got it, its all about the hidden question. I open some other excel file, and I did not click the "enable editing". this make freezes every time I copy some column. The problem solved when I click the "enable editing". how this help

2

Removing Office 2013 update KB3114717 did the trick for me. I found this after running the MS OffCAT tool for Office. CPU is back to normal and Excel doesn't freeze when doing copy/paste.

https://support.microsoft.com/en-us/kb/2939112 https://support.microsoft.com/en-us/kb/3114717

1

The easier way to display the background running question if it is a response/question popup is to right-click mouse at a clear section in the task bar and select Tile windows vertically rather than selecting Show Desktop to show all active windows.

1

I had same problem. It was an issue with Conditional Formatting and Copy/Paste/Undo etc. The paste must be a Paste Special and Merge Conditional Formatting Paste and not the default. Else the CF fragments.

I created a shortcut key to VBA script that automatically did this paste. So instead of a Ctrl+V the user does a Ctrl+S (or hits a button) which runs a macro that is:

Selection.PasteSpecial Paste:=xlPasteAllMergingConditionalFormats, Operation _
        :=xlNone, SkipBlanks:=False, Transpose:=False
3
  • Nooooo! Never use Ctrl+S for a custom macro. Everybody uses that to save in every application ever written for Windows, right? Imagine the fun if someone else uses your "customised" workbook: "WTF? I just tried to print, but it just closed and deleted the current workbook (Ctrl-P = Put in trash)" or "Whaaat!? I just tried to open a workbook but I ended up surfing P0rn (Ctrl-O = Online P0rn as Ctrl-P is already in use) " ;-) – robinCTS Jun 11 '18 at 1:21
  • @robinCTS, thanks for the hint. I had no idea I could quickly jump to my online porn with Ctrl-O. That will save me a lot of time. :-) – fixer1234 Jun 11 '18 at 1:44
  • @fixer1234 Just be careful at work now. Far too easy to accidentally start playing porn whilst the boss is watching over your shoulder ;-) – robinCTS Jun 11 '18 at 2:25
1

Running Excel for Office 365 MSO (16.X). Found that if I have two Excel files open, one was opened from my local drive, the 2nd opened from an email and loaded in protected view when I try copy from the first file which is Not in protected view it hangs and I'm forced to close file. If I reopen the first file from my local drive, close the 2nd file in protected view I have no problems with copy/paste. If I reopen the file from the email (loads in protected view), then click Enable editing on the 2nd file, return to the first try copy/paste I have no problems.

To summarize if I have a file open in protected view it causes copy/paste to freeze with any other file that I have open so enable editing on everything you have open.

1
  • Goto File => Options => Advanced tab
  • Goto Cut, copy, and paste section.
  • Uncheck: Show Paste Options button when content is pasted
  • Uncheck: Show Insert Options buttons
  • Uncheck: Cut, copy and sort inserted objects with their parent cells
1
  • Welcome to SuperUser. This is not a forum. It's a Question and Answer site. You posted this as an answer so it needs to simply and clearly explain how to solve the problem. I can help you edit your post to be more clear. – HackSlash May 16 '19 at 23:12
1

For those of you who read through all of these answers and did all of these things to no avail, I have another thing for you to try that worked for me. Like you, I read and did all of these things and they didn't help.

In my case, Office 2010 version of Excel (32bit) on Windows 7, the program would freeze for MINUTES not seconds.

I noticed that the amount of RAM that Excel.exe was using would approximately triple while the program was frozen, and that dwm.exe was using about one core of CPU (12-13% on a quad-core w/ HT versus 1-3%). I used Process Explorer and took a complete dump of Excel while it was frozen, then installed and ran WinDBG (good beginner guide which is all I used found here), and learned that there was "heap corruption".

In this case, Windows updates hadn't been applied for YEARS, and I found out Service Pack 2 for Office 2010 was one of them (https://www.microsoft.com/en-us/download/details.aspx?id=39667). This computer was also being offered an update KB3078667 which has to do with a memory leak that occurs in Desktop Window Manager (dwm.exe).

After installing and rebooting, the problem went away. Hope this helps somebody else out there, as it's not just exclusive to Office 2010.

This security bulletin is applicable, look at it and see if you have this update installed or a superseding one that has one of these in it, if not, installing one of these may ameliorate your problem.

0

I have a spreadsheet of Corn prices that covers 20 years - 1000 worksheets. I also have some worksheets at the end showing the results (graphs, etc.) of various scenarios. From time to time I try different things and re-use existing columns on the price worksheets. All of a sudden when I hit ctrl+C (copy) it froze and I got a 'not responding'.

One of two things fixed it. I got rid of some of the summary worksheets - now if works. Either: I had hit some Excel limit as far as what it could handle but I don't think that is likely. What is more likely is my new use of one of the existing columns was an 'IF/THEN' code that returned a text answer rather than a numerical answer. I believe the freezing was due to one of the existing summary sheet items (graphs, etc.) expecting a number field and finding a text field.

0

For me it was a weird program, a virtual machine, that hooks into clipboard and monitors it. Closing that program solved the issue.

0
  1. If your problematic copy-paste workflow is including calculations, ask yourself why you are doing that. Your workflow may need to be revised.
  2. Complex non-plaintext data could be getting in the way. Test this by making a plain-text-only and numbers-only new document, by copying individual columns, pasting into Notepad, copying into columns in the new document.
  3. There may be hidden rows and columns that are getting copied along with the visible portion. There may be hidden data by pivot tables, so that the actual amount of data being transferred is much bigger than expected.
  4. If the file size is big, you may be overwhelming the PC. Modern Excel files are actually ZIPped XML files. At one place I worked at, an Excel sheet was causing problems on old PCs, so I tried manually unzipping it (renaming it .zip and using 7Zip to expand it). The 200 MB archive came out to over 2 GB of plaintext.
0

If you have a Protected Cells in a Protected Sheet, you may get the same error as well.

Please Unprotect your sheet and then do your action, either select, copy or paste.

0

Maybe not directly related to any of the issues above, but I had a user who was copy/cut from one tab to another tab within a same sheet, and Excel was freezing. It ended up the cells from the source tab was locked. Once I unlock the cells (highlight the cells, right click and format cells, under protection tab, uncheck Locked), then paste wouldn't freeze Excel.

0

Another solution is to check for hidden picture objects. I found that the excel document had hundreds of hidden image items that weren't visible. The below steps are from https://blogs.office.com/en-us/2009/01/30/hidden-and-invisible-objects/

The first thing you want to do is verify that you have additional objects on your spreadsheet. The easiest way to view a sheet’s objects is to turn on the on the Selection Pane (on the Home Tab go to the Editing Chunk > click the Find and Select Dropdown > select the Selection Pane option making the pane visible). Looking at the selection pane you will see a list of all objects on the current sheet and an indication if the objects are visible or hidden. If the selection pane is blank then you do not have extra objects on the sheet.

The top of the Selection and Visibility Pane for my sheet. Notice that 100 objects were pasted into my document. I have seen customer files with thousands of hidden objects.

Once you have the selection pane open and verified that you have objects on the sheet, the next step is to put your spreadsheet in Design Mode if it is supported on your current workbook. Design Mode will only be enabled in Excel if your sheet contains certain types of controls. Turning on Design Mode will allow you to select all controls, not just the basic shapes and form controls. To enter Design Mode select the Design Mode button in the Controls Chunk on the Developer Tab. If this button is disabled in the Ribbon then your sheet does not contain the types of controls that require this step. (Note: If you do not have the Developer Tab visible in the Ribbon you can enable it with the following steps: Office Button > Excel Options

check the “Show Developer tab in the Ribbon†checkbox on the default Popular tab).

You now are ready to select objects using the Go To Special dialog. To select all objects in the sheet: Ctrl+G to open the Go To dialog > select the Special button > select Object > click OK. The objects will then be selected and their selection handles are visible on the sheet.

My sheet with all objects selected. You can see that in addition to the previously visible objects I now also have selected some textboxes previously hidden on my sheet.

At this point you can simply hit the Delete key and remove all of these objects from the sheet. You can also choose to be more selective about the objects you delete; if you have other objects already on your sheet you wish to keep, ctrl+clicking the objects in either the selection pane or on the sheet will remove them from the current selection prior to hitting delete.

0

i opened the clip board and turned off all the options. problem fixed.

open the clip board by clicking the arrow at the bottom right corner of the home tab. At the bottom left of the clip board click options. Uncheck all the options.

0

I've had this problem for some time and I have a file with a ton of conditional formatting. I unchecked "Enable Live Preview" and things seem to be working way better now. Hopefully this helps someone else as well.

0

My issue was resolved by a READ ONLY warning banner on a mail window behind the worksheet I was in. Once I unlocked for editing, the worksheet functioned normally again.

1
  • 1
    Can you elaborate on this answer? What exactly did you encounter and what did you do to solve it? Very unclear to me... – confetti Aug 15 '18 at 10:43
0

To me on Win10 helped "Troubleshoot compatibility" on Excel shortcut. System fixed something and the problem disappeared.

1
  • This is not an answer, it is a comment. Please delete this post and make it a comment on the original posting. – Rich Michaels Jun 6 '19 at 11:21
-1

I experienced this issue as well today, and I was absolutely clueless as to why Excel was freezing up for ~20 seconds whenever I tried to copy something. I most of the suggestions mentioned in this question, to no avail.

I later found out during the same day that my C:\ drive (the installation drive for MS Office) apparently didn't "have enough" empty space. It was odd, since I already had 10 GB free. Regardless, I simply emptied up another 10 GB on that drive, and copying inside Excel is working fine again.

So, if you haven't found a solution yet, I suggest freeing up some space on the drive you have Excel installed on. That might just be the trick.

Not the answer you're looking for? Browse other questions tagged or ask your own question.