5

I have the strangest problem I have ever faced and I can't figure out what's going on. It started today after a few hours of full shut down. It had occurred once a few weeks ago, but I can't remember what I did to solve it (I think it went away after some time.)

My laptop's BIOS is continuously pressing some key. I can't figure out which key but all I know it's most likely some alphanumeric key. So far the only text fields I could actually get access to are password fields (asking for Windows password). I can't type the password because it gets filled with this keypress and it's real fast. I have tried to use FilterKeys (I can turn it on through the login screen's accessibility button) - it slows down the continuous stream of keypresses, but it's not slow enough for me to put my password in.

I am sure this is not a Windows problem because the whole computer is down to a crawl right from the moment I flip the power switch. Even in the BIOS setup screen I'm finding it doesn't respond to keypresses half the time, and I have to hold keys down to get the BIOS to respond to them. Also, wherever there is a mouse pointer, I can use both internal trackball and external wireless mouse (Logitech proprietary) to control it without any problem.

The other thing I noticed is that sometimes I have to press the Bluetooth switch a couple of times to get the BIOS to pass the baton to Windows when booting. The switch is always turned on when the BIOS boots, but once turned off it cannot be turned on again. Also BIOS appears stuck until I press the Bluetooth switch, upon which Windows starts to load (or show startup options).

I don't even know where to start with this. Here are things I have tried:

  • Remove/reseat/try different configurations of the two RAM cards I have (2 x 1GB).
  • Remove wireless module.
  • Remove/reseat internal hard disk.
  • Remove/reseat internal keyboard hardware. Even with the keyboard hardware removed the keypress is still happening. When connected the internal keyboard fails to respond completely (including Caps Lock).
  • Remove all power sources (AC and battery) for 5 to 10 minutes. The computer is stuck pressing the key and removing power doesn't seem to help unstuck it.
  • Use an external wired keyboard. It partially works - the keyboard buffer is still being filled with the continuous keypress but at least I can send my own keypresses (like Tab and Caps Lock, arrow keys etc.) to the system and get it to respond some of the time.
    • Actually the external wired keyboard works completely, but its signals are usually getting drowned out by those from the internal that is stuck. Sometimes the computer gets the signals but other times I have to compete with the internal and overcome the drown-out by hitting the keys several times or holding them.
    • I got to the BIOS setup screen by using the external keyboard. I couldn't do it at all with the internal keyboard.
  • Using safe mode - I can't get past the password stage. The loading up of drivers is also incredibly slow (I know from past experience Windows does it fast) but eventually it will get to the password prompt.

I'm gonna have to rip my whole laptop apart and try removing the CMOS battery. I have ripped the laptop apart before but it's very time-consuming hence I want to find some other solution first. I don't know if removing the battery will help.

This laptop is quite old now (think 2006) but I have gone lengths to repair it myself and save it several times from imminent death (so to speak). I'm hoping to save it one last time as I'm not in the right situation to go out and buy a brand new laptop. But I'm guessing I have to do that, sadly.

5
  • You don't have a paired Bluetooth input device (keyboard, etc.) under a pile of junk on your desk or squeezed in a drawer or bag, do you? When you said you tried removing the wireless module, was that a combo Wi-Fi/Bluetooth module, or just one of those two? If you haven't tried removing the Bluetooth module, try that. – Spiff Mar 6 '12 at 4:05
  • I'm not sure if it's a combo module (I don't think so) but it has a cable that connects to the WiFi antenna. In the specs doc it's just called Intel Wireless Pro 2915ABG network connection 802.11a+b+g. There is no separate removable Bluetooth module. I'm 100% sure there are no paired Bluetooth devices around (I don't own any + I have never paired any). – ADTC Mar 6 '12 at 4:18
  • Bluetooth radios are always separate devices from the motherboard because otherwise the whole motherboard would have to get FCC/ETSI and other radio regulatory agency approvals. It's just way easier and cheaper to have it be a separate module. See if the Bluetooth module is located near the Bluetooth switch. Or maybe look at the hardware device tree and see what bus the Bluetooth radio attaches to, for ideas of where it might be. If it's on the same PCIe bus as the Wi-Fi module, then it may well be a combo card after all. Standalone Bluetooth radios often connect to USB, not PCIe. – Spiff Mar 6 '12 at 4:26
  • Another thought: That external wireless mouse...is it Bluetooth or something else? If it's something else, do you leave that radio plugged in all the time? Does the problem go away if you disconnect that radio? If the mouse is Bluetooth, does the keypress problem go away if you switch off (or remove the batteries from) the mouse? – Spiff Mar 6 '12 at 4:30
  • @Spiff the wireless mouse is Logitech proprietary, not Bluetooth. It has its own USB receiver and I have tried removing it - the problem remains. I'll try to find the Bluetooth module when I rip the laptop apart (not gonna do it right now). It's not in the easily accessible pockets (like RAM and hard disk). Btw I can't get into Windows to look at Device Manager, though I can access the hard disk through another computer and an USB to IDE bridge (which means an external casing). – ADTC Mar 6 '12 at 4:39
4

The internal keyboard controller may be faulty, or the keyboard connector may be damaged or shorted.

This behavior is unlikely to be caused by software, and since you stated that the laptop keyboard is entirely nonfunctional but an external keyboard works to an extent, I would suspect that the laptop's internal keyboard electronics are at fault. The parts in question are probably on the motherboard itself.

8
  • Exactly my thoughts actually. Guess there isn't a solution short of replacing the motherboard (I'd rather go for a new laptop then). – ADTC Mar 6 '12 at 4:14
  • > but an external keyboard works to an extent It works completely, but the external keyboard’s signals are getting drowned out by the internal that is stuck. :-( – Synetech Mar 6 '12 at 4:38
  • @Synetech yes, that's actually correct. I didn't know how to word it. Hope you don't mind if I copy your wording :) – ADTC Mar 6 '12 at 4:42
  • Nope, that’s fine. I’ve seen the same effect due to either a secondary keyboard with a stuck key, or an overloaded CPU, ie. high-priority process running at 100% (preventing they from handling input in real-time). From the sounds of it, it seems that the internal keyboard is indeed “stuck” in some manner. – Synetech Mar 6 '12 at 4:47
  • 1
    @roadev: Weird... then it looks like some electrical problem on the mainboard (or in the wiring). I suppose you'll need to have it serviced. – sleske Jan 26 '16 at 8:35
1

If you are using windows Vista or 7, before starting insert a flash drive and then turn on PC. I suppose (like you are saying) you cannot enter password because one key presses itself, but underneath the password slot/space there is a reset password option, click on it (with USB flash inserted). A pop-up will occur and from it you will be able to see the problematic key. Sort it out.

1
  • That would have been possible. To this day I don't know what key was stuck. Wish I has thought of that earlier. I sold the laptop for parts shortly after. – ADTC Oct 18 '14 at 2:08
0

If you are able to get into BIOS Setup, I would suggest a DOS boot disk from Bootdisk.com That should tell you which key is being pressed, if you can get to change the boot setup.

-1

I had a similar problem with an old hp compaq nx9010, that was left uncharged for very long, did not have a password on windows XP SP3 so I could actually see which key was sent all the time and that key was a comma (",")! I tried to solve the "problem" as above, reset BIOS etc, removed the internal keyboard and had it checked and cleaned, external keyboard would behave the same as the internal one. Pressing "Esc" might work for a while. After hours of searching the internet about any similar problem I came to the conclusion that it may be the CMOS battery. Unfortunately I have to rip half the notebook apart to get to it so I let it for three days on AC charging despite the fact that the Notebooks' battery is dead. (Had read somewhere that the internal battery actually charges) Turned it on after three days now and the "problem" seems to have vanished. This is one of the weirdest problems I ever came across. Hope this helps someone with a similar problem. Try prolonged charging the Notebook first, so as the CMOS battery gets charged, before waisting your time disassembling the Notebook.

1
  • Welcome to Stack Exchange! We appreciate your input, however we observed that it isn't formatted well into paragraphs and also not proofread for mistakes. I suggest that you can edit your answer to make it well-written. Thank you! – ADTC Aug 11 '19 at 10:50
-3

I have this problem. Best solution is to press the f4 key or Esc on start up you can then type your password and all is good.

1
  • We discourage a very short answer like this. Can you please expand how this solve the problem? – Vylix Sep 8 '17 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.