I have a Lenovo x200 and recently its screen didn't work, so I took it to a repair lab. The guy told me they replaced the screen inverter. I powered up the laptop and the ThinkPad logo was shown, so I was happy. When I got home the computer would boot up, then instead of the logon screen, I got a black screen. Went to safe mode, disabled the display adapters, reset the computer, and I got a clean boot. Then I tried to reinstall the drivers, and it just led to the same condition. My video card is (from device manager): Mobile Intel(R) 4 Series Express Chipset Family.

Now my laptop works as I'm working with display drivers disabled, but without display drivers I can't watch movies, etc. Any solution to this problem?

Edit: I plugged in an external monitor and it works on it with display drivers enabled. However, it does not find the laptop monitor.

Edit 2: I tried every solution suggested here, except going back to the repair lab, as I left for a trip abroad when this happened and it seemed quite a while has passed, so I figured they wouldn't hold themselves accountable.

  • I edited the question. It works (I can surf the web, etc.), but with the display drivers disabled. – Amir Rachum Mar 8 '12 at 17:55
  • @AmirRachum Download an Ubuntu LiveCD, boot it, and see if the problem's fixed. That way we can determine if it's a hardware or software problem. – BinaryMage Apr 1 '12 at 1:34
  • @BinaryMage great idea! plugged in an ubuntu usb and it worked right off the bat! – Amir Rachum Apr 3 '12 at 18:15
  • @AmirRachum Glad to hear it, that narrows it down significantly. Answered with my recommendation, hope it works. :) – BinaryMage Apr 4 '12 at 0:55
  • Have you followed my suggestion from Mar 28 and went back to the repair lab ? It would also be a good idea to recap in your post everything that you have tried. – harrymc Aug 13 '12 at 5:57

Maybe it is stuck in projection only display mode. Most laptops have a button combination to cycle through these options and one is to only use external monitor. According to the user manual it is the Fn+f7 key. Try cycling that with the display driver enabled and the computer turned on.

Lenovo x200 user Manual

| improve this answer | |
  • Fn+F7 doesn't help. – Amir Rachum Mar 10 '12 at 17:43
  • Only way to really test it is to hook an external display. If it works on the external display it will isolate the video card as the faulty device. – Phillip R. Mar 10 '12 at 18:14
  • On the computer I am currently using (A Compaq Presario), to switch to the external display Fn+F7 is used. – cutrightjm Mar 11 '12 at 20:36
  • I am thinking his video card is bad. – Phillip R. Mar 11 '12 at 21:43
  • @PhillipR. please see my edit. – Amir Rachum Mar 18 '12 at 17:45

Have you tried VGA mode? It sounds like its possible that the driver you are using is trying to default the screen to a resolution that is not supported by the monitor itself. Do you have an additional external display that you can hook it up to, and see if it broadcasts to that properly?

Also, please try VGA mode, and see if you can adjust the resolution from there to the native for the LCD.

EDIT: Irony in its finest form. I currently have a Dell Latitude E6410 with the EXACT same issue. Works great on external display with drivers installed. Works great on internal LCD with NO drivers installed. Install drivers? No longer works on internal. Dell is shipping me a motherboard, not sure why, but they seem to think the video card is bad. I will update once it gets here and I replace it. The E6410 is using the Intel HD graphics chip.

| improve this answer | |
  • VGA mode (actually the only similar option was Low Resolution Mode, which I assume is the same) didn't work. Unfortunately I don't have the connectors to plug in my other screen (which uses a DVI connector). – Amir Rachum Mar 10 '12 at 17:23
  • please see my edit. – Amir Rachum Mar 18 '12 at 17:46

I'd give installing the drivers another try. Go to http://support.lenovo.com/en_US/downloads/default.page? and select your model, and find Video in the list. You should be able to see the Intel GM45 Display Drivers there.

It might be worth uninstalling anything display related first to remove any special settings that might persist.

Failing all of that, perhaps reinstall Windows.

| improve this answer | |
  • +1 Laptop OEMs produce their own drivers because they are optimised for the specific display/motherboard configuration. Installing drivers from the graphics chipset manufacturer may actually cause you problems. – Tog Mar 28 '12 at 21:22

Given that an Ubuntu LiveCD worked, it's clear we have a software problem on our hands.

First, we must remove any "bad" or potentially bad drivers.

  • Uninstall anything remotely related to video drivers. Lenovo software, Intel drivers, chipset drivers, and the like. You can always reinstall some of it later, but for now it's better to eliminate any possible driver conflicts.
  • Go into Device Manager (Start -> Type "Device Manager -> Enter), find your videocard (under display adapters), click the "Driver" tab, click "Uninstall" and go through the process to remove the driver (if any still exists)

Now, we should be able to install the correct drivers.

  • Close any running applications and save work (we will be rebooting the computer).
  • Download the appropriate video drivers from Lenovo's website. Windows 7 video drivers for the x200 are here (32-bit) and here (64-bit).
  • Download the display information file, also from Lenovo's website. The file for the x200 can be found here (both architectures).
  • Right click both download files and make sure no properties are amiss. (Specifically, make sure Compatibility Mode is disabled)
  • Right click the display driver file (7xd558ww.exe or 7xd658ww.exe) and select "Run as administrator". Accept the User Account Control warning if it pops up and install the drivers, accepting all defaults.
  • When finished it may prompt you to reboot. Do not accept.
  • Install the display information file the same way. (Right click, "Run as administrator")
  • If it prompts you to reboot upon completion, do so. Otherwise, reboot manually.

Assuming no esoteric Windows issues are present, that should fix the problem. My guess is that whomever repaired your laptop somehow removed the display file (that would explain why the external monitor but not the laptop screen worked) and forgot to reinstall it.

| improve this answer | |
  • Doesn't work :( – Amir Rachum Apr 4 '12 at 6:44
  • If this is a software issue, I'm considering just reinstalling Windows. My laptop got sluggish anyway. – Amir Rachum Apr 4 '12 at 6:44
  • Giving you the bounty since the live CD was a good idea in the right direction. – Amir Rachum Apr 4 '12 at 6:45
  • @AmirRachum I'm sorry; this did seem the likely culprit IMO. This certainly should have fixed the issue if it was a driver problem, but I guess should wasn't good enough in this case. If you have a backup or a system restore point, I'd try that, otherwise reinstalling is probably the easiest method at this point. In any case, best of luck, and if you run into any issues, I'm always glad to help. – BinaryMage Apr 4 '12 at 15:11
  • 2
    @AmirRachum Ubuntu uses the videocard; there's no other way to output to a display. It uses a different, open source driver. Try running glxgears in a terminal off of a LiveCD, that should test the videocard more completely than just booting a LiveCD. – BinaryMage Apr 6 '12 at 23:25

I believe this is a conflict issue with the Intel HD drivers. I had a similar issue, my thinkpad would hang on a black screen for over two minutes as Windows 7 booted. However, if I booted in Safe Mode of with the Intel drivers disable, I'd have the regular a fast boot time.

I think I solved this problem (fingers crossed) by uninstalling the intel drivers, deleting any intel registry values at:



HKEY_CURRENT_User/Software/Intel/ICC/Applications/Intel Graphics Driver

After that, I rebooted, then reinstalled the latest Intel HD drivers.

Problem Solved!

| improve this answer | |

Does this laptop have a special "lenovo" utility? This could be something like a hotkey driver or a system device manager. Since the monitor works without the driver I believe it is a configuration somewhere that is preventing the display from showing properly. If the Intel driver utility is installed, you can open up the display manager from the system tray and change the configuration of the displays.

You could also try removing then reinstalling the display driver. Might wipe out the setting if the uninstaller cleans everything correctly.

| improve this answer | |
  • The Lenovo utility is not installed. The Intel driver utility does not detect the laptop monitor (only the external one), and reinstalling does not solve the problem. – Amir Rachum Mar 20 '12 at 20:42

In believe that going back to the repair lab is the indicated solution.

It is likely that they got something wrong.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.