I have just started playing around with Git and would like to push a personal project to a newly created, private repo on Bitbucket using Aptana Studio 3. I tried to use the Git integration in Aptana but I couldn't figure out where to enter my username and password for Bitbucket anywhere. I tried using the Team > Share Project context menu but that keeps throwing the following message:

Warning: Permanently added the RSA host key for IP address '' to the list of known hosts. Permission denied (publickey). fatal: The remote end hung up unexpectedly

I'm pretty sure that's because my repo is private. However, I couldn't find a provision to provide any form of credentials for linking to a private repo.

Any ideas?

1 Answer 1


You used the SSH link to clone your repository. For this to work you need to do one of the following:

  1. Use ssh-keygen to generate a private key, and add the equivalent public key to bitbucket.
  2. Just use https, and enter your username and password each time (or store it in .netrc)

It doesn't matter that your repo is private, your problem is in authentication to bitbucket.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.