I have two computers running Windows 7 Professional. Each is on a different network using NAT. Both are joined to the same Hamachi mesh network. Both machines can ping the other and browse the other's file shares. Each computer is also running a web server (Google app engine on one, IIS on the other). Even though they can ping and share files with the other, neither can connect to the other's web server. I tried accessing each by navigating to http://5.xxx.xxx.xxx:8080 (The Hamachi IP and web server port). Is some additional configuration required? I didn't think a proxy is necessary since I'm not trying to route traffic through the other.

P.S. My end goal is to log live sensor data on one machine and send it to the other using a web service (which already works as long as I can actually the other machine's web server).


1 Answer 1


It looks like you have two options. Either disable the firewall on the Hamachi Tun Virtual Network Driver or open up the firewall so that communication on port 8080 is allowed. You most likely had your IIS Server open on port 80 which was probably added as an exception on your firewall. However port 8080 was not added to the list.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .