16

I am experiencing strange problem with using my touchpad and keyboard simultaneously under Windows 7.

I have HP tx2550ew (convertible tablet), and when I hold some key under Windows 7 (eg. space, a, s etc.), the touchpad seems to be blocking.

I spotted this while playing Counter Strike. I am not playing much games, and I haven't been playing CS since January, so I am not sure when it started behaving like that. I have tested it also outside the game - when I hold space (eg. when on some web page and entering text into input field) or some letter key, the cursor is not able to move.

The problem seems to not be occuring when I hold Shift, Ctrl nor Alt.

Did any of you experience similar problem? Do you know what may have caused this? Is there any way I could check what is wrong with my laptop?

I have been looking for a solution, but it seems I haven't been looking in right places. This is why I ask question here.

Ps. I am unable to test whether this is touchpad-specific, because I have no mouse at my disposal at the moment (got used to touchpad so much I even find it more efficient and haven't been using a mouse with my laptop for months).

1
  • 1
    I experience the same thing with a Synaptics touchpad on an Acer laptop. I noticed it because of kakuro.com where you have to hold Space while clicking the mouse to switch to pencil-mode. It works if I hold Space and press the left mouse button, but not if I tap the touchpad. Of course tapping the touchpad without holding Space works fine for a normal click for entering the number in non–pencil mode.
    – Synetech
    Nov 6 '12 at 16:08
10

Notice that the Space, a, and b keys repeat. Holding the a key will send many a characters as input. Shift, Ctrl, and Alt do not repeat. The system detects them as being pressed and released.

It sounds like your system is setup to turn off the touchpad while typing. It considers pressing the a key as typing. It may consider holding the Ctrl key as an option for the touchpad, e.g. hold Ctrl+touchpad click.

Consider going to your touchpad configuration. Looking for an option where the touchpad turns off while typing. I haven't worked with your specific model, or an HP, but my ThinkPads have had the option.

8
  • 3
    Yes, I noticed the difference between [Ctrl] and [a], thus I pointed it out. The problem here is that I did not change that option (if it exists). I looked through all the options, beginning with Mouse properties, through device settings, to the properties of Synaptics TouchPad V6.3 on port PS/2 (note: it is built-in in the laptop). I think it may be some kind of driver update that came with Windows Update's regular update, or some kind of malfunction. I did not reinstall my OS since 2010. Could you tell me which specific option are you talking about?
    – Tadeck
    Mar 11 '12 at 1:31
  • Sorry. I have had a few Thinkpad and other PC laptops. I currently use a Macbook so I can't be more specific. One additional thing to check is if you have a hard button on the laptop. I have seen ones in the past where you could press a hard button and it would turn the touchpad off. If you have one, and it is "on", then it may be preventing use while typing. Mar 11 '12 at 5:13
  • Also let me add that even if you had a mouse to test with, I am not confident it would help. The mouse may work while pressing these keys. But, if I recall correctly, the setting is specific to touchpad on a ThinkPad. Mar 11 '12 at 5:18
  • See @Cory's answer below Jan 13 '13 at 0:04
  • 1
    I have a ELAN touchpad and the same issue. I tried editing the registry from @Chaitu's answer but that didn't fix it. Apparently it was actually a thing with Windows 10. I went to Settings > Devices > Mouse & Touchpad > Touchpad > Delay: no delay
    – user458498
    Oct 26 '16 at 23:10
9

Found the answer on a different site.

Start -> Mouse (search) -> Device Settings -> Settings (select Synaptics LuxPad) -> Palmcheck-enhanced ACM -> Palmcheck -> Adjust the slider to Off. This works perfectly on all HP ProBook models.

4
  • 1
    I had already turned the Palm Sensitivity setting down a couple of notches a while back to get a 3D game to work, but for some reason kakuro.com was being more troublesome. I just tried turning it down more (I had to go all the way to the bottom) and it worked, but of course it increases the likely hood of false mouse movement, therefore I simply turned the Touch Sensitivity setting up a little.
    – Synetech
    Nov 6 '12 at 16:18
  • 1
    i have a brand new Dell XPS L521X, i noticed the problem playing Starcraft 2 using Touchpad and A Key simultaneously, disabling SmartSense on Synaptic Touchpad settings there fix the problem. pD :: someone can report this kind of bug to synaptic ppl?? Aug 1 '13 at 9:37
  • additionaly, i recommend uninstall dell synaptic specific driver and install oficial driver from synaptics.com, it bring much more possibilites Aug 6 '13 at 21:21
  • This solution also works with the "Synaptics pointing device" on Windows 10; the slider is titled "Palm Check Threshold" and instead of off, sliding it to the lowest of "Low" has the same result.
    – Davy M
    Aug 23 '19 at 23:31
4

I have experienced the same problem. If the touchpad you are using is elantech, this works. In run dialog type regedit.

Go to

HKEY_CURRENT_USER -> Software -> Elantech ->Other settings.

Check for Options

DisableWhenType_Enable and set the value to 1.

This works for maximum cases and if doesn't check DisableWhenType_AllArea and set its value to 1.

3
  • 2
    Actually, setting its value to zero (0) makes you able to use the point simultaneously with the keys
    – Dave Beer
    Dec 7 '12 at 2:26
  • Also, check out en.community.dell.com/support-forums/laptop/f/3518/t/… for dell 15 notebooks using Elantech toupads. Jan 7 '13 at 18:01
  • Actually, I found this value in HKEY_CURRENT_USER > Software > Elantech > SmartPad
    – user458498
    Oct 26 '16 at 22:47
4

I had the same problem when playing Team Fortress 2. I went to Control Panel → Hardware and Sound → Mouse → Touchpad, then to touchpad settings. There was no PalmCheck option, but there was one called TouchCheck. I just turned that off and I can play TF2 now.

1

As @AgelessEssence said: Go to Mouse properties>Device Settings>Settings>Smartsense and turn it off like the image below.

enter image description here

Worked on Windows 10 Pro with Synaptics driver. (In my case, I have a Toshiba Satellite S45).

1
  • I encountered this problem in graphics editing (Paint.NET, Photoshop, Photopea.com) where holding space bar and dragging should pan around the image but it doesn't. I have a newer version of this driver which has two additional settings "Tapping disabled time after keystroke" and "Pointing disabled time after keystroke". Tried both left extremes and right extremes on both settings. Unfortunately nothing worked. For "Pointing", if I place it on left extreme, the cursor moves for a second before it locks up but it doesn't grab or pan the image.
    – ADTC
    May 8 at 4:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.