So, today I was stupid, and left my laptop powered on and in my backpack for a few hours. When I took it out, the battery which had been fully charged was almost out of charge.

So, I power cycled it, and when it came on, the BIOS took extra long to start, and then the following text appeared:

    Broadcom UNDI PXE-2.1 v2.1.0
    Copyright (C) 2000-2006 Broadcom Corporation
    Copyright (C) 1997-2000 Intel Corporation
    All rights reserved.
    PXE-E61: Media test failure, check cable
    PXE-M0F: Exiting Broadcom PXE ROM
    Operating System not found

So, the first thing I tried was booting off an Ubuntu 8.04 Live CD, which worked, but it could find no traces of my hard drive (even after cooling my hard drive in a fridge for ~20 minutes).

I still have a warranty from Dell. Has anyone found that they cover this sort of thing (and preserve the data)? I'll be calling them soon anyways, but I won't bother if it's a waste of time.

If I have to recover the data myself, what are the best options? Is there anything free, or should I pay a disk recovery service? Which programs/services are the best?


In the first instance, definitely call Dell as it is under warranty - that is what you paid the extra premium for (unless you were lucky and got it free). They will talk you through checking all the settings in the BIOS to ensure they are correct for your computer.

I would personally check if the disk is recognised in the BIOS and check that the boot order is correct. The excessive heat may have reset the BIOS settings. I have seen stranger things happen.

Seeing the PXE boot (boot from the network) message is quite a common thing with desktops, it is just a method of booting from the network. Sometimes it is below the harddisk in the boot order so you don't always see it come up.

You should be able to remove the disk and use a disk caddy to connect it to another working computer, usually via a simple SATA/IDE to USB connector. As long as the disk is not fried, you will be able to copy your existing data off.

In terms of data recovery, you will not have any luck doing it from your laptop if it is not recognised by the BIOS. If it is recognised using the disk caddy but unreadable, you might still be able to use something like R-Studio (which comes at a cost).

  • Thank you so much! I can't believe I didn't think of going into the BIOS. The only setting I changed was to print diagnostic information, and when I restarted, everything was back to normal! Whew... – Nate Parsons Sep 11 '09 at 23:55
  • 2
    Glad to hear! Now's the time to get a backup of what's on your disk while you can. Sure it'll be fine but always best to be on the safe side. – Kez Sep 12 '09 at 0:09
  • Well, I should have listened to you about the warranty the first time. After 2 more rounds of putting my hard drive in the fridge, and a corrupted system file (at least I listened to you about the backups!) I have a free replacement hard drive on the way. – Nate Parsons Oct 19 '09 at 9:35
  • And I feel super silly, because it was really an issue with my external HD. I didn't realize that every time I removed the internal HD, I was also unplugging the external... :/ – Nate Parsons Oct 2 '10 at 3:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.