I bought a Toshiba Satellite P755D recently and installed Windows 7 Professional on the machine. It runs great. But I noticed the exclamation point in the yellow triangle icon in the Device Manager next to the Universal Serial Buss (USB) Controller (I'm assuming this is the USB 3.0 controller because mine doesn't recognize devices). Normally, when this kind of thing happens I go to the manufacturer's website and download appropriate drivers and call it a day.

But not this time...

I browsed to my model and found no driver for the USB 3.0 controller. I tried other HW and Utility drivers, thinking they would be bundled. No luck. I tried looking up the motherboard in my machine. Generic name, no luck.

I then called Toshiba technical support and they tried basic troubleshooting, eg, uninstall device, reboot, for auto-installation; no luck. I popped the Windows 7 disk back in and tried to get information that way, no luck.

Finally, the technical support guy said he would look into the engineer's system to see if there was a specific driver available and that's where I'm at. The technician told me that these USB 3.0 drivers come within the native driver pack in windows but that doesn't seem to be the case.

Any ideas?

Device Manager - Yellow Exclamation Mark USB Device Properties Window, No Drivers installed

  • Please add the info from Device Manager about this USB controller. – harrymc Mar 15 '12 at 16:56

I put your laptop details into Toshiba UK support site and it listed two USB 3 drivers for your system:


  • Good option, but both of these drivers I have tried to no avail ( when the problem first started... they showed up on another Toshiba site)... Oh yah, I only found 2: Satellite P, P755, Windows 7 64-bit, USB-driver. – nicorellius Mar 16 '12 at 2:50
  • Does it have an AMD Chipset - There are some USB 3 drivers contained in the Chipset driver package: support.amd.com/us/gpudownload/windows/Pages/raid_windows.aspx – BJ292 Mar 16 '12 at 14:14
  • Yes it does, and I tried the drivers for the chip-set according to Toshiba. I will try your recommendation and see what's up as well. Thanks. – nicorellius Mar 16 '12 at 16:39
  • You got it! That worked... I previously installed a chip-set driver package from the Toshiba support site that I thought had these drivers but it didn't. I guess I should have gone to the AMD site. Anyway, thanks a bunch for your help. Enjoy the +50. – nicorellius Mar 16 '12 at 16:49

Here is a link to AMDs Chipset drivers.

I had a similar problem and these were the drivers that fixed it for me.

  • Rather than try to get around the 30 character limit by posting garbage all you had to do was to say that the link is for AMDs chipset driver and that you believe that this is the missing driver. – Mokubai Nov 12 '13 at 22:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.