I have a weird problem that I have never encountered before. This problem is intermittent with no discernible trigger.

Hitting the 'c' on my keyboard does not produce the 'c' character on my screen (in all applications, for example 'notepad'). Hitting Shift-'c' produces a Capital 'C' every single time. Opening up the on-screen keyboard and clicking on the 'c' there also does not produce a 'c' character.

At one point I thought that I had fixed it by switching to an alternative keyboard layout scheme (English US -> English SA) where it had this problem on the US layout but not the SA layout. Now it has the same wrong behavior on both layouts.

Any ideas what might be causing it?

  • Have you installed any new fonts recently?
    – Tog
    Mar 12, 2012 at 7:19
  • No new fonts installed, but this happens in all applications, regardless of which font is being used. Mar 12, 2012 at 9:16
  • Have you performed a malware scan?
    – Michael K
    Mar 12, 2012 at 9:20
  • It is a corporate machine that gets scanned often and has limited access to the internet/wilderness. Mar 12, 2012 at 10:57
  • @PieterBreed - Just because its a coporate machined does not mean it cannot be infected. That actually makes it much more likely it is. Furthermore "limited" internet access still means its connected to the internet.
    – Ramhound
    Mar 12, 2012 at 11:46

5 Answers 5


I believe that this is a problem with Chrome, but, I have no proof or confirmation.

I have also had this problem just last week - I was typing in Chrome and a page was working find but then all of a sudden, mid-sentence c key stopped working. It may have been something else, but, it has only happened once to me and I was unable to work it out.

...it stayed not working even when Chrome was shut, and, as I was busy, I didn't have time to fix it.

In the end, I just restarted my computer and it was all fine.

So, sorry, no idea what is causing it, but, at least there is a fix!


This seems to be some Chrome-specific problem indeed, but might be linked to Dell laptops, too.

Have a look at this Google support thread.

Posts there suggest to try pressing the Windows key or the Ctrl five times.

EDIT: There's an issue tracked for Chromium, too.


This just happened to me. Letter c did not work, but SHIFT+c worked.

Press the LEFT or RIGHT WINDOWS KEY two times to get out of this mode.

This can happen because Windows switched into some sort of multi-character input mode, like Japanese. Has something to do with switching into alternate keyboard layouts.

  • 1
    For me it was the left windows key twice that fixed it Mar 10, 2023 at 15:19

Just happened to me on my computer. Windows and using Internet Explorer. I came upon this site searching for an answer. None of the answers seemed to apply to me, so I went back to my keyboard...

I hit "ESC" key and the letter "c" works again.


Happens to me sometimes. Pressing the Fn key plus the Windows key twice on my Lenovo fixes it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .