I recently changed the default search engine to a custom google search URL (using baseUrl) with some additional parameters and removed all the rest of the search engines, and since then, the search predictions stopped working.

I even tried to reinstall Chrome but as soon as I resync, the problem is back! Search predictions are just gone without option to fix!!

In IE changing the search provider allows specifying a prediction (suggestion) provider, In chrome, once you change the default search engine, you'll never be able to have predictions again!! This is a terrible bug, I mean WTF!!!

Is there any workaround to that?

I posted a bug report a while ago but it seems no one looks at it. I'm about to give up on Chrome and go back to IE, the only good thing about Chrome is the Extension market and the AdBlocker (which I can find in IE as well). The perfrormance changes don't matter to me too much.


  • 2
    Not that that would help you any further with your issue, but I would recommend you keep the swearing to a minimum and punctuation to the appropriate level when reporting bugs. It helps to get taken more seriously. – Der Hochstapler Mar 12 '12 at 13:31
  • @OliverSalzburg OK makes sense, tx sry, but do you agree that this is a blocking issue?? – Shimmy Weitzhandler Mar 12 '12 at 20:33
  • Shimmy please don't use SMS abbreviation here like tx or sry. – avirk Apr 1 '12 at 4:20
  • @avirk, I was typing it from my phone... – Shimmy Weitzhandler Apr 1 '12 at 5:51


Stop sync and remove all of your synced data.

After relaunching Chrome, the problem should be solved.

  • 1
    how will this help him? He has stated that after he syncs, predictions are lost. This will still sync his search method, which will break prediction again. – Myrddin Emrys Mar 12 '12 at 19:21
  • @Zac I've tried the solution again, seems I've missed part 2. Although a very frustrating solution, did work. Anyway no need. to follow the entire guide, just step 2. – Shimmy Weitzhandler Mar 29 '12 at 3:04

The "stop sync and remove all synced data" trick worked for me. Unfortunately the steps have changed slightly and it is now "Disconnect Google Account" > choose YES to remove all data. I shut down Chrome (and the 8(!!!!) instances still running in Task Manager, then just re-launch Chrome and re-sync and it's fine.


After trying @ZacB's suggestion, it still didn't work. Removing all Chromium's settings and rebooting the computer also didn't work, so I concluded that the Chromium version I was running must be buggy.

Updating Chromium fixed it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.