47

My question has been asked on superuser before, but the accepted answer did not work for me.

Sometimes when using remote desktop on my Windows 7 computer, the copy-paste functionality between the remote desktop and my computer suddenly stops working. How can I restore it?

I have looked at Fixing copy/paste for Remote Desktop Connection sessions and SQLAuthority News – Fix : Remote Desktop Copy Paste Stop Working

But killing and restarting rdpclip doesn't seem to work for me. How can I fix this?

This is driving me a bit crazy. Restarting the computer or the remote desktop connection doesn't work either. Anyone have any ideas?

42

You can run the following commands on your remote machine one by one.

Taskkill.exe /im rdpclip.exe
Rdpclip.exe

This is a temporary fix, alternately you can use an online copy paste tool.

  • Its not working, answer below works BTW. – digz6666 Aug 29 '16 at 8:48
  • This does not work in some circumstances. Add the /f option to taskkill.exe. – Brown Aug 29 '17 at 17:45
  • Note : I had 2 chained remote desktop sessions (because of security reasons) and needed to restart rdpclip on both sessions allthough only the last one failed. – SemVanmeenen Mar 2 '18 at 14:11
37

Using the command prompt to kill/start rpdclip.exe on both the local and remote system was unsuccessful. A few minutes later, finally what did work was:

  1. Open Windows Task Manager on the Remote server.
  2. Under the Processes tab, find rdpclip.exe in the list, right click, End Process.
  3. Use command prompt to restart rdpclip.exe.

(Unknown how this is different from TaskKill, but it worked. Maybe timing is involved.)

  • 5
    This worked for me. The answer above about using command prompt didn't work for me. – FastTrack Mar 7 '15 at 15:22
  • This worked... until the next RDP session. Signing out (end the windows session) and then signing in on the remote machine resolved my problem. – Eren Aygunes Dec 29 '16 at 6:14
  • I tried all this and not sure why but when my file was names "fonts.zip" I could not copy it to the remote server.. I copied a txt filed from and then back too it was OK? I renamed the fonts file and it worked. WTF! ? :( Then I renamed the original file back to fonts and it worked again. Very strange – Piotr Kula Jan 26 '17 at 14:01
8

This worked for me in Windows 8.1. I entered these one after another:

taskkill.exe /F /IM rdpclip.exe
rdpclip.exe
  • 2
    You saved my friend. – NullPointer Oct 19 '16 at 6:49
4

Did you make sure that "Local Clipboard" was chosen in your RDP "Local Resources" tab?

enter image description here

  • 5
    yes. And it was working, and then suddenly stopped – stuck Mar 12 '12 at 21:33
4

Try the following steps :

In local computer: (mine was windows 7)

1) Connect using the following setups:

 Remote Desktop Connection window ->options->select checkbox "Clipboard"

2) Restart local rdpclip.exe

You have to stop the process called rdpclip.exe. Then you go to Run, and write rdpclip.exe to restart this process.

In remote computer:(mine was windows server 2008)

1)Allow clipboard redirection

Click Start-->run-->type mmc

On the File menu, click Add/Remove Snap-in.

Under Available Stand-alone Snap-ins, click Group Policy Object, and then click Add-->finish-->ok.

In the left panel tree select "Local Computer Policy\Computer Configuration\Policies\Administrative Templates\Windows Components\Terminal Services\Terminal Server\Device and Resource Redirection"

In the right panel select "Do not allow clipboard redirection" right click->edit and select "disabled" radio button.

In the left panel tree select "Local Computer Policy\User Configuration\Policies\Administrative Templates\Windows Components\Terminal Services\Terminal Server\Device and Resource Redirection"

In the right panel select "Do not allow clipboard redirection" right click->edit and select "disabled" radio button.

2) enable remote desktop clipboard redirection

To enable or disable the redirection of local devices and resources On the RD Session Host server, open Remote Desktop Session Host Configuration. To open Remote Desktop Session Host Configuration, click Start, point to Administrative Tools, point to Remote Desktop Services, and then click Remote Desktop Session Host Configuration. Under Connections, right-click the name of the connection, and then click Properties. In the Properties dialog box for the connection, click the Client Settings tab.

Under Redirection, do one of the following for a given local device or resource category: Select the check box to disable redirection of that type of local device or resource. Clear the check box to enable redirection of that type of local device or resource. Click OK.

3)Restart remote rdpclip.exe You have to stop the process called rdpclip.exe. Then you go to Run, and write rdpclip.exe to restart this process.

After the above steps try reconnecting remote desktop and you will be able to copy paste from local/remote to remote/local

  • Still not working. :/ – Dan Apr 30 '15 at 14:35
2

Reconnecting to RDP server helped me. I was able to paste to the server but not backward.

protected by Community Aug 8 '15 at 15:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.