The Ctrl+a (select all shortcut) does not work in Firefox on Linux mint 12; I mean if you highlight a textbox (for example in google.com the box where you enter the search keyword ), enter some text and then press Ctrl+a, it will not select all the text you inserted before but instead it will move the character cursor to the beginning of the line. The odd thing is that if you press Ctrl+a and you are not highlighting a textbox it works just perfect. Also for the same user if i use the MATE layout(select it when I login) everything works just fine. (Now I'm using the gnome 3 layout). If I create another user everything works fine. Is there any way I can fix this thing or should I create a new user and enjoy the new identity :)


Is there any way I can fix this thing?

Answer: Yes. If you want to put the time into it, you can certainly fix this. That's one of the great things about Linux. You can probably fix this simply by editing some text config files (or possibly making a new Firefox profile). See below.

Diagnosis: it seems like your user has a setting that is invoking the line editor for text boxes. You can verify this if ctrl+e moves to the end of the line, ctrl+b moves back one letter, ctrl+f forward one letter, etc.

It is not possible for me to say, based on the info in your question, whether the configuration issue is in your Firefox profile or in Gnome 3. (I don't use Gnome 3.)

Possible Solutions:

  1. Rather than make a new user, consider making a new Firefox profile. If that works, delete your current user's existing Firefox profile and use a new one.

  2. check, edit and possibly delete your current user's customized Gnome 3 configuration files (usually hidden files such as .profile) in the home directory.

  3. of course, since you know that making a new user account fixes the issue, that's one very easy solution. If you want to further diagnose this, do a diff on the various config files until you find the cause of the problem in your first user account.


It might be the case when you turn on Emacs Input mode.

To reverse the behavor, first open Gnome Tweak Tool application (mine v3.30), then go to Keyboard & Mouse section. After that, you might see the Emacs Input toggle enabled (which cause that strange behavior). Disable it.

Disable the toggle.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.