14

For the longest time the Media button on my keyboard used to launch Winamp. I don't remember having to do anything to set that up. But suddenly now the button launches stupid Windows Media Player when I press it. I have tried everything I can think of to change it back. Winamp is set to open all the filetypes it can. It is set as my default media player (from Default Programs > Set program access and computer defaults). When I go to Default Programs > Set Default Programs there is only a small list of programs there and Winamp is not one of them and there doesn't seem to be anyway to add or remove programs from that list. I don't no what the point of that silly thing is.

I tried re-installing Winamp. I looked through the Windows Media Player options, nothing there. I considered uninstalling or disabling WMP but that isn't easy and I'm not sure if I want to do that anyway. My keyboard doesn't have any special drivers installed and I can't find any for it, BenQ doesn't support it anymore. It worked fine before without drivers anyway.

So the question is where is the magic place to set what the Media Button does? Something in the registry?

  • 2
    What model of BenQ keyboard do you have? What version of Windows are you running? – aportr Mar 14 '12 at 23:57
18

On Windows 7 (and since Windows ME apparently) these enhanced keyboard keys can be handled directly by Windows using the APPCOMMAND system.

The associations for these keys are stored in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AppKey.
(It can be overridden, per user, by adding it in HKCU as well I think).

AppKey 16 is the "Media Launcher" key (APPCOMMAND_LAUNCH_MEDIA_SELECT). By default it has an association with .cda (Audio CD's).

So which ever program you have set as the program to handle Audio CD's will be what opens when you hit the Media Launch key.

I have Winamp currently set to control .CDA files (Winamp-->Options-->Preferences-->General Preferences-->File Types), and it opens when I hit the "Music note" key on my Logitech with no additional drivers installed.

| improve this answer | |
  • Nicely done! Strange, in the Winamp preferences it is set to open CDs but when I actually checked Default Programs > Set Associations, .cda was indeed set to Windows Media Player. Finally! Thanks dude. – Moss Mar 15 '12 at 2:08
  • Yeah, Winamp's internal association setter and Win 7's "Program Defaults" associations don't play well togeather. :) – Ƭᴇcʜιᴇ007 Mar 15 '12 at 12:16
  • 4
    Nice way! Instead of changing the file association of .cda files, I would recommend to add another text value named "ShellExecute" to key 16 where you just specify the path to your winamp.exe or desired program. Of cause you are supposed to remove the association value to .cda. – user425088 Mar 5 '15 at 8:55
  • @flex, thanks! Just what I needed. You should post that as an answer. I wanted to launch the Windows 8 Music app, but it doesn't seem possible to associate it to the .cda extension. So I just created a ShellExecute value with microsoftmusic: as its content. – Thomas Levesque Aug 19 '15 at 15:06
  • What about other hot keys? (I have 14 hotkeys+a scroll wheel to control the volume, but in registry, theres only five AppKeys) – RogUE Jan 24 '16 at 11:30
3

This is the real thing you have to do to make anyprogram be default of media button: Startmenu-> Control Panel-> All Control Panel Items-> Default Program-> Associate a file type of protocol of program -> ... find .cda, click on it and click "Change program..." -> Choose any media program you want like Jetaudio or Winamp -> OK

Then you can instead open your program by pressing media button.

| improve this answer | |
  • did not work for me on windows 10 – Ev0oD Jun 5 '16 at 14:18
3

In Windows 8.1

  • Control Panel\Programs\Default Programs - Set program access and computer defaults
  • expand "custom"
  • in "Choose a default media player" select "winamp"
| improve this answer | |
  • 1
    Please be aware, that this overrides all file associations – binco May 23 '15 at 18:14
  • This also works for Windows 10. Adding on to this, you can set the rewind, pause/play, forward buttons like so: Open up the Winamp Preferences and the browse down to General Preferences \ Global Hotkeys. The first thing you should check is whether the “Enabled” hotkey is checked. If it’s not, then select that and most likely that will fix your issue. Source: howtogeek.com/howto/windows/… – Onosa Jun 22 '16 at 21:00
  • More specifically in Windows 10 it goes by what is associated with MP3s – Mark Sowul Feb 15 '18 at 3:44
2

http://www.winamp.com/help/Winamp_Preferences_guide#General_Preferences:_Global_Hotkeys

The Winamp Preferences screen is accessible via the Bento or Modern skin by selecting 'Preferences' from the 'Options' menu.

It can also be accessed in all skins by hitting Ctrl+P on your keyboard, when Winamp is the focused application.

General Preferences: Global Hotkeys

  • Enable default multimedia key support: Will attempt to process media keys by using WM_APPCOMMAND messages ('off' by default). Try checkmarking this option if your Play/Pause, Stop, Previous & Next keys aren't recognized by just using the 'Enable' Global Hotkeys setting below.
  • Enabled: Checkmark this to enable Global Hotkeys. Global Hotkeys can be used to perform actions (Play, Stop, Next, Previous, Rate Items, Copy Title, etc) even when Winamp isn't the active application.
  • Action: Select which extra hotkeys to enable via the drop-down menu.
  • Hotkey: Use your keyboard to select a unique hotkey for the selected action (eg. hold down Ctrl + Shift + H) then click the 'Add' button.
| improve this answer | |
  • 3
    Link-only answers are discouraged here at SU due to potential future link-rot. Please include pertinent information in your answers. – Ƭᴇcʜιᴇ007 Mar 15 '12 at 0:23
  • 1
    Sorry. I've copied the information now. – matthewk Mar 15 '12 at 0:40
  • Sorry, not exactly the problem I was having. The play control keys were actually working, just not the app launch button. I did have the WM_APPCOMMAND button checked but it made no difference. Anyway, problem solved. – Moss Mar 15 '12 at 2:10
2

In Windows 7 run registry, go to

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AppKey.

AppKey 16 is the "Media Launcher" key. By default it has an association with .cda (Audio CD's).

Delete value "Association". Creat new value "ShellExecute" (REG_SZ type) and as data set path to the program.

E.g: ShellExecute = c:\Program Files\foobar2000\foobar2000.exe

| improve this answer | |
  • What does this add that the accepted answer doesn't? – Burgi Mar 7 '16 at 11:48
1

For Windows 10 I had to change the default app for Music player:

Settings -> System/Apps (depending on Windows build) -> Default Apps -> Change Music player

| improve this answer | |
0

For Windows 8.1 (32-bit) this is the simplest solution:

Control panel >
Default programs >
Associate a file type or a protocol with a specific program >
Click MP3 under Extensions >
Change program

| improve this answer | |
0

There is another solution which, in my opinion, is a little more elegant. Not sure if it's still needed as the original question was answered more than 5 years ago, but I hope it will be useful to someone:

  • Run RegEdit and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AppKey

    As Ƭᴇcʜιᴇ007 mentioned in the accepted answer, your Media button is AppKey 16

  • Delete the Association registry key in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AppKey\16

  • Add a new String Value key and name it ShellExecute

  • If you have Winamp installed, set the value simply to winamp

  • If Winamp is not installed in your system, like when you just have it in a folder or it's a portable install, a refugee from the previous OS, or if the previous step does not work for some reason, set the value to the absolute path of your Winamp executable, e.g. C:\Program Files (x86)\Winamp\winamp.exe

Now your Media button should run Winamp exclusively.

You can actually make media keys run any other programs, BAT files, VBS scripts or shell commands using the same technique.

| improve this answer | |
-1

For Windows 10 LTSC Settings -> Apps -> Default Apps -> Music Player change the default Program to Winamp

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.