122

I've a device I connect to my windows computer (in this case it is an iPod but I don't believe that matters). Often when I first connect such devices a dialog will pop up giving a list of actions with a check box saying something like "do this as the default" or "always do this".

For some reason when I first used this device I selected open a folder to view files and had the always check-box checked. I wish I'd pressed do nothing, now when I connect the device this annoying file folder pops up and I just have to close it.

How can I get the default USB action for this device to change?

2
  • What OS are you using? XP, 7, 8 CB?
    – wizlog
    Mar 15, 2012 at 15:14
  • I'm using Vista but I was guessing it did not matter -- judging by your answer it doesn't.
    – Hogan
    Mar 15, 2012 at 15:45

1 Answer 1

175

Microsoft explains all about autoplay here.

  1. Open AutoPlay by clicking the Start button , and then clicking Control Panel. In the search box, type autoplay, and then click AutoPlay.

  2. In the list next to the device or type of media, click the new action you want to use.

8
  • I'll check this out when I get home. Is there where it stores defaults for a specific device? It seems only my iPod takes this action.
    – Hogan
    Mar 15, 2012 at 15:47
  • @Hogan - The default is stored in the registry. There are ways to basically forget about the device. I suggest just using wizlog's advice.
    – Ramhound
    Mar 15, 2012 at 16:17
  • 1
    This solved my problem and the display contains device specific settings at the bottom. Thanks!
    – Hogan
    Mar 16, 2012 at 19:18
  • The stored device name is shown in the Autoplay window. You can reset all defaults too. That's what I did. @wizlog Thanks for the info.
    – noob
    Sep 25, 2014 at 13:11
  • 5
    btw/fyi - This same explaination works with Windows 10
    – user487801
    Aug 24, 2015 at 16:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.